directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <>
Subject Re: [Shared] [Schema API] Shouldn't getName[s] really be getAliases[s]
Date Sun, 30 Aug 2009 08:53:38 GMT
Alex Karasulu wrote:
> Thoughts?

>From RFC 4512:
   The NAME field provides a set of short names (descriptors) that are
   to be used as aliases for the OID.

So there are at least three synonyms for the same thing.

I'd use the terms defined in the ABNF and that is 'NAME'. Otherwise also
many other methods could be renamed (e.g. getMayAttributeTypes could be
named getAllowedAttributeTypes or getOptionalAttributeTypes).

My 2 cents,

View raw message