directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [Studio] Upgrade in UI tests
Date Thu, 04 Jun 2009 14:33:11 GMT
Ok, done.

The good thing is that we now could use JUnit4 :-)

Two notes:
- Please install the newest SWTBot plugins (currently Build
2.0.0.340-dev) from [1] into you Eclipse, otherwise the
test.integration.ui plugins can't compile.
- UI tests now only run in an Eclipse 3.5 runtime. To run UI tests from
command line please make sure to install an Eclipse 3.5 runtime and
update your .m2/settings.xml file. To run UI tests from within Eclipse
you need to update at least your target platform to Eclipse 3.5.

Kind Regards,
Stefan

[1] http://www.eclipse.org/swtbot/downloads.php

Emmanuel Lecharny schrieb:
> On Tue, Jun 2, 2009 at 12:24 PM, Stefan Seelmann <seelmann@apache.org> wrote:
>> Hi guys,
>>
>> I'd like to upgrade the dependencies of the Studio UI tests:
>>
>> - Eclipse 3.5 (RC3 is available atm) as test runtime: Eclipse 3.4 comes
>> with JUnit 4.3, which prevents us to use the JUnit 4.4 based server
>> intergration test framework. Eclipse 3.5 includes JUnit 4.5.
>>
>> - Use our nice server integration test framework.
>>
>> - Newest SWTBot snapshot which comes with a lot new features and
>> improvements.
> 
> go for it !
> 



Mime
View raw message