directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@apache.org>
Subject Re: Help connecting phpldapadmin to ApacheDS 1.5.1
Date Sat, 16 May 2009 18:12:27 GMT
Chris Mattmann wrote:
> Hi Kiran,
>
> Thanks. I've attached my server.xml and my custom EDRN schema file. Comments
> below:
>
>
> ayyagarikiran wrote:
>   
>> As you mentioned these are not operational attributes.
>> Did you try using any other LDAP client( e.x Apache Directory Studio)?
>> If not can you try any other and see the difference
>>
>>     
>
> Interestingly enough Apache Directory Studio seems to work fine. That is,
> when I bind as Directory Studio and try to modify my entry attributes it
> allows me to, and AFAICT, it only allows me to edit the attributes and
> entries that I should be able to. PLA; however, is reporting something
> different.
>   

You then probably have to contact the PLA developers... Studio is built 
on top of JNDI, so its totally Server agnostic. It will work the very 
same with any other LDAP server. If somethiong can be done with STUDIO, 
which can't be done with PLA, I don't really see how it can be a problem 
with the server. Or may be PLA is adding some controls to the request 
the server does not support ?

The only thing you can done to check what's going on is to analyze the 
requests being sent to the server and the response being returned. Using 
Wireshark could help.

-- 
--
cordialement, regards,
Emmanuel L├ęcharny
www.iktek.com
directory.apache.org



Mime
View raw message