directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rahul.soa" <rahul....@googlemail.com>
Subject Re: ApacheDS 1.5 - Build failure
Date Sun, 08 Mar 2009 13:53:47 GMT
Hi Emmanuel,

I also tried with SUN java 1.6 too and getting the same error.

[root@localhost ApacheDirectoryStudio-linux-x86-1.4.0-SNAPSHOT]# java
-version
java version "1.6.0_12"
Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot(TM) Client VM (build 11.2-b01, mixed mode)
[root@localhost ApacheDirectoryStudio-linux-x86-1.4.0-SNAPSHOT]#
./ApacheDirectoryStudio
0    [main] INFO  org.apache.directory.studio.Application  - Entering Apache
Directory Studio.
13574 [main] INFO  org.apache.directory.studio.Application  - Exiting Apache
Directory Studio.
^C[root@localhost ApacheDirectoryStudio-linux-x86-1.4.0-SNAPSHOT]#

Regards,
rahul

On Sun, Mar 8, 2009 at 12:52 PM, Emmanuel Lecharny <elecharny@apache.org>wrote:

> Stefan Seelmann wrote:
>
>> Emmanuel Lecharny wrote:
>>
>>
>>> In my case, even a ^C does not allow me to quit.
>>>
>>>
>>>
>>
>> Is there any message in ~/.ApacheDirectoryStudio/.metadata/.log ?
>>
>>
> No.
>
>> Could you please create a thread dump using kill -3 ?
>>
>>
> I can't : it does nothing.
>
>> Could you try with other JVMs?
>> e.g. ./ApacheDirectoryStudio -vm /opt/apache-harmony-jdk-5.0-M6/bin/java
>>
>>
> Tested with sun 1.5.0_15 : same blockage
> Tested with sun 1.6.0_10 : same blockage
> Tested with sun 1.7.0 : same blockage
> Tested with jrockit-R27.4.0-jdk1.5.0_12 : works fine
> Tested with jrockit-R27.4.0-jdk1.6.0_02 : works fine
> Tested with ibm_java2_i386-50 : works fine
> Tested with ibm_java_i386-60 : works fine
> Tested with Gij-4.3 : slow like death...  Exit correctly. Got some errors :
> elecharny@elecharny-laptop:~/ApacheDirectoryStudio-linux-x86-1.3.0.v20081020$
> ./ApacheDirectoryStudio -vm /usr/bin/gij-4.3
> 0    [main] INFO  org.apache.directory.studio.Application  - Entering
> Apache Directory Studio.
> exception thrown: java.lang.ClassNotFoundException:
> org.apache.directory.studio.ldapbrowser.core.model.schema.AttributeValueEditorRelation
> not found in
> gnu.gcj.runtime.SystemClassLoader{urls=[file:/home/elecharny/ApacheDirectoryStudio-linux-x86-1.3.0.v20081020/plugins/org.eclipse.equinox.launcher_1.0.100.v20080509-1800.jar],
> parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}} -
> message:
> org.apache.directory.studio.ldapbrowser.core.model.schema.AttributeValueEditorRelation
> not found in
> gnu.gcj.runtime.SystemClassLoader{urls=[file:/home/elecharny/ApacheDirectoryStudio-linux-x86-1.3.0.v20081020/plugins/org.eclipse.equinox.launcher_1.0.100.v20080509-1800.jar],
> parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
> exception thrown: java.lang.reflect.InvocationTargetException - message:
> null
> 746643 [main] INFO  org.apache.directory.studio.Application  - Exiting
> Apache Directory Studio.
>
>
> So it seems to be a SUN JVM related problem...
>
>
>
> --
> --
> cordialement, regards,
> Emmanuel L├ęcharny
> www.iktek.com
> directory.apache.org
>
>
>

Mime
View raw message