directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: ApacheDS 1.5 - Build failure
Date Tue, 17 Mar 2009 07:45:09 GMT
Hi Rahul,

rahul.soa wrote:
> Hello Stefan,
>  
> This time build was successful but the old problem still persists :(
> (i.e. failure in integration tests).  * The build was successful before
> as well but the main problem was with running tests.
>
> message="org.apache.directory.shared.ldap.schema.Syntax.getSyntaxChecker()Lorg/apache/directory/shared/ldap/schema/SyntaxChecker;"
> type="java.lang.NoSuchMethodError">java.lang.NoSuchMethodError:
> org.apache.directory.shared.ldap.schema.Syntax.getSyntaxChecker()Lorg/apache/directory/shared/ldap/schema/SyntaxChecker;
>     at
> org.apache.directory.server.schema.registries.DefaultRegistries.resolve(DefaultRegistries.java:229)
>     at
> org.apache.directory.server.schema.registries.DefaultRegistries.resolve(DefaultRegistries.java:283)
>     at
> org.apache.directory.server.schema.registries.DefaultRegistries.resolve(DefaultRegistries.java:326)
>     at
> org.apache.directory.server.schema.registries.DefaultRegistries.resolve(DefaultRegistries.java:470)
>     at
> org.apache.directory.server.schema.registries.DefaultRegistries.resolve(DefaultRegistries.java:434)
>     at
> org.apache.directory.server.schema.registries.DefaultRegistries.resolve(DefaultRegistries.java:434)
>     at
> org.apache.directory.server.schema.registries.DefaultRegistries.checkRefInteg(DefaultRegistries.java:185)
>     at
> org.apache.directory.server.core.DefaultDirectoryService.&lt;init&gt;(DefaultDirectoryService.java:230)
>     at
> org.apache.directory.server.unit.AbstractServerTest.setUp(AbstractServerTest.java:254)
>     at
> org.apache.directory.studio.test.integration.core.JNDIConnectionWrapperTest.setUp(JNDIConnectionWrapperTest.java:63)
>

I'm not sure why you get this error. The test start up an embedded
ApacheDS, 1.5.5-SNAPSHOT is used.

Could you please delete you local maven repository in ~/.m2/repository
and build again?

Thanks for you patience,
Stefan


Mime
View raw message