directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@apache.org>
Subject Re: [ApacheDS] Strange problem with LDAP clients connecting from remote (Can't connect to the LDAP server - Unknown error)
Date Sun, 08 Mar 2009 18:03:08 GMT
Stefan Zoerner wrote:
> Emmanuel Lecharny wrote:
>> Can you provide those frames, plus the server logs ?
>
> Here are the frames:
>
>
>
> Frame 1 (74 bytes on wire, 74 bytes captured)
> Ethernet II, Src: Intel_42:f1:b4 (00:03:47:42:f1:b4), Dst: 
> Sony_29:8a:28 (00:13:a9:29:8a:28)
> Internet Protocol, Src: 192.168.9.33 (192.168.9.33), Dst: 192.168.9.31 
> (192.168.9.31)
> Transmission Control Protocol, Src Port: 57109 (57109), Dst Port: 
> 10389 (10389), Seq: 0, Len: 0
>
>
> Frame 2 (54 bytes on wire, 54 bytes captured)
> Ethernet II, Src: Sony_29:8a:28 (00:13:a9:29:8a:28), Dst: 
> Intel_42:f1:b4 (00:03:47:42:f1:b4)
> Internet Protocol, Src: 192.168.9.31 (192.168.9.31), Dst: 192.168.9.33 
> (192.168.9.33)
> Transmission Control Protocol, Src Port: 10389 (10389), Dst Port: 
> 57109 (57109), Seq: 0, Ack: 1, Len: 0
>
>
> 192.168.9.31 runs the ApacheDS on 10389. 192.168.9.33 is the remote 
> client.
>
> I have attached the WireShark protocol as well (I am a little bit 
> uncertain, which format you need).
>
> The server logs are basically empty.
> Greetings from Hamburg,
>     Stefan

Seems like you just have a preliminary TCP ack, and that's it. I have to 
test it, it seems that MINA 2.0 behaves differently than MINA 1.0. By 
default, when setting the Acceptor without any parameter, it uses the 
localHost. Not what you want, probably.

You can change the address in the TcpTransport configuration for the 
LdapService :

    <tcpTransport>
      <tcpTransport address="<your server address>" port="10389" 
nbThreads="8" backLog="50"/>
    </tcpTransport>

Can you give it a try ?

-- 
--
cordialement, regards,
Emmanuel L├ęcharny
www.iktek.com
directory.apache.org



Mime
View raw message