directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSTUDIO-427) Operational attributes turned on by itself
Date Sun, 08 Mar 2009 12:36:56 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-427?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12679983#action_12679983
] 

Stefan Seelmann commented on DIRSTUDIO-427:
-------------------------------------------

There is some 'magic': When "Show Operational Attributes" is turned off and you add an operational
attribute or an attribute not specified in the schema then it is turned on automatically.

Maybe we should rethink about this "Show Operational Attributes"  checkbox. 

Currently it has two functions:
1st: A filter function for the entry editor. When displaying the attributes of an entry there
is a check if it is operational. This is the case if the usage differes from "userApplications"
or if the attribute type doesn't exist in the schema at all.
2nd: Whether to fetch operational attributes from the directory or not (add a "+" to the list
of returned attributes or not)

I think it would be better so separate these concerns:

The "Show Operational Attributes"  checkbox should only have the filter function, like the
other checkboxes "Show objectClass|must|may attributes".

Whether to fetch operational attributes from the directory should be configured diffently.
I'd like to suggest to add an option in the connection properties for this which fetches operational
attributes for each entry. Additional we should make it possible to fetch operational attributes
on a per-request basis.

Thoughts?

> Operational attributes turned on by itself
> ------------------------------------------
>
>                 Key: DIRSTUDIO-427
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-427
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-ldapbrowser
>    Affects Versions: 1.3.0
>            Reporter: Aleks M
>
> Hi
> Working against Novell eDirectory 8.7.3.9
> When I click the New attribute button and add the userPassword attribute Directory Studio
automatically turns on the display of operational attributes and I have to go to Preferences>LDAP>Attributes>Entry
editor to turn them off again.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message