On Tue, Feb 17, 2009 at 4:56 PM, Emmanuel Lecharny <elecharny@apache.org> wrote:
Alex Karasulu wrote:
Funny I was writing revertAndClear() but decided to delete that from my
email. I did this because the clear(), clear(int) and revert() constructs
are RISC and sufficient in combination.  Up to you tho.

I will see. Not really a big deal to do one operation or two though.

The separate clear() and revert() operations decouples functionality.  The revertAndClear() operations both couples functionality together.  You might find situations where you just need to clear() or just to revert() and sometimes to do both as is the case now.  When we break things down into simpler functions that do one thing and only one thing well then it's easier to recombine them to suite different situations.  This may also lead to better interface design.