directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Zoerner (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (DIRSERVER-1316) apacheds.bat in noarch installer causes NoClassDefFoundError on Windows
Date Sat, 28 Feb 2009 14:58:12 GMT

     [ https://issues.apache.org/jira/browse/DIRSERVER-1316?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stefan Zoerner resolved DIRSERVER-1316.
---------------------------------------

    Resolution: Fixed

Only two lines modified, and it runs now
http://svn.apache.org/viewvc?view=rev&revision=748862

Thanks Felix for the work!

> apacheds.bat in noarch installer causes NoClassDefFoundError on Windows
> -----------------------------------------------------------------------
>
>                 Key: DIRSERVER-1316
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1316
>             Project: Directory ApacheDS
>          Issue Type: Bug
>         Environment: Windows XP, SP 2
> Cygwin
> Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
>            Reporter: Stefan Zoerner
>            Assignee: Stefan Zoerner
>             Fix For: 1.5.5
>
>
> After building the installers as descroibed here
> http://directory.apache.org/apacheds/1.5/02-building-trunks.html#0.2.Buildingtrunks-Buildingtheinstallers
> I have unzipped the apacheds-1.5.5-SNAPSHOT.zip
> Starting the server via apacheds.bat causes an error.
> StefanZ@oose-sz /cygdrive/c/java/apacheds_1.5.5-SNAPSHOT$ ./apacheds.bat
> Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/directory/server/UberjarMain
> Caused by: java.lang.ClassNotFoundException: org.apache.directory.server.Uberjar
> Main
>         at java.net.URLClassLoader$1.run(Unknown Source)
> Problem is probably within here (from apacheds.bat):
> for /F %%a in ('dir lib\ /a /b /-p /o') do set ADS_CP=%ADS_CP%;"lib\%%a" 
> The variable ADS_CP does only contain the last jar-file in lib, the concatenation within
the for loop seems not work. For each iteration, the value for %ADS_CP% in the set operation
seems to be still the old one ("").

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message