The method name is fine. It is intended to denote cleanup of resources needed for the CL.
This in memory CL was a very very simple proof of concept implementation. I added the code to backup the content of the CL to a file which get's read on startup to persist changes instead of loosing them. This mimics a real persistent CL for testing purposes. If you change this then several tests will begin to fail. The point is any CL should persist change events, even if this implementation is just a toy.
On Wed, Jan 28, 2009 at 7:05 PM, Kiran Ayyagari <firstname.lastname@example.org> wrote:Probably :)
> AFAIU, the destroy in CL is intended for flushing the changes and closing
> the open resources
> rather than for removing. I have implemented a custom CL's destroy() in the
> same way.
> May be the method name is misleading.