directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <akaras...@gmail.com>
Subject Re: [ChangeLog] Destroy() method semantic
Date Thu, 29 Jan 2009 14:14:05 GMT
The method name is fine. It is intended to denote cleanup of resources
needed for the CL.

This in memory CL was a very very simple proof of concept implementation.  I
added the code to backup the content of the CL to a file which get's read on
startup to persist changes instead of loosing them.  This mimics a real
persistent CL for testing purposes.  If you change this then several tests
will begin to fail.  The point is any CL should persist change events, even
if this implementation is just a toy.

Alex

On Wed, Jan 28, 2009 at 1:14 PM, Emmanuel Lecharny <elecharny@gmail.com>wrote:

> On Wed, Jan 28, 2009 at 7:05 PM, Kiran Ayyagari <ayyagarikiran@gmail.com>
> wrote:
> >
> > AFAIU, the destroy in CL is intended for flushing the changes and closing
> > the open resources
> > rather than for removing. I have implemented a custom CL's destroy() in
> the
> > same way.
> >
> > May be the method name is misleading.
>
> Probably :)
>
> --
> Regards,
> Cordialement,
> Emmanuel L├ęcharny
> www.iktek.com
>

Mime
View raw message