directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric C (JIRA)" <j...@apache.org>
Subject [jira] Created: (DIRSTUDIO-436) Eclipse Hangs on Startup
Date Wed, 10 Dec 2008 14:04:46 GMT
Eclipse Hangs on Startup
------------------------

                 Key: DIRSTUDIO-436
                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-436
             Project: Directory Studio
          Issue Type: Bug
    Affects Versions: 1.3.0, 1.2.0
         Environment: Windows XP Pro
Eclipse Ganymede
Directory Studio 1.3
            Reporter: Eric C


Intermittent problem, seemingly dependent on what editor is open when eclipse is closed. 

If I have a .jsp open in an editor window (or .xml) and in focus, when restarting eclipse
it will hang.

The workaround to this is to delete all the <editor>...</editor> elements and
their content from the workbench.xml eclipse file. If I have multiple editors open, sometimes
I have the patience to find the one that is causing the problem and just delete that element
from the workbench.xml.

When I close Eclipse with a .java file open in an editor and in focus, I do not have this
problem.

I have had this problem for months, and was having a bear of a time figuring out what was
causing this, and a teammate installed this plugin (at my behest, and later to my embarrassment)
and his Eclipse hung when restarting. I cleaned his workbench.xml of open editors and it came
up fine. He had installed 1.3, and had an xml file open at the time. I updated my version
to 1.3, and can still reproduce the hang by simply closing Eclipse with an open jsp file.

I could probably produce a stack dump while hung if it would help, but I'm not proficient
enough with RCP to debug the problem myself.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message