directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Norval Hope (JIRA)" <j...@apache.org>
Subject [jira] Created: (DIRSERVER-1283) installers/apacheds-noarch no longer builds apacheds-noarch-installer-1.5.5-SNAPSHOT-app.jar
Date Tue, 28 Oct 2008 04:15:44 GMT
installers/apacheds-noarch no longer builds apacheds-noarch-installer-1.5.5-SNAPSHOT-app.jar
--------------------------------------------------------------------------------------------

                 Key: DIRSERVER-1283
                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1283
             Project: Directory ApacheDS
          Issue Type: Bug
    Affects Versions: 1.5.5
         Environment: C:\src\ad-1.5\apacheds>mvn -version
Maven version: 2.0.9
Java version: 1.6.0_10
OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"
            Reporter: Norval Hope
            Priority: Blocker


Doing a "mvn install" or running installers/apacheds-noarch/apacheds.bat no longer results
in consolidated *-app.jar file. I tried the following:
  1. remove my maven respository
  2. mvn clean (at top level)
  3. mvn install (at top level, and with the usual 10 or so restarts of my build every time
it failed to download some random library I've never heard of - man I hate maven!).
  4. cd <top>/installers/apacheds-noarch
  5. run apacheds.bat

At this point installers\apacheds-noarch\target\apacheds-noarch-installer-1.5.5-SNAPSHOT.jar
exists (16kb) but nothing I can think of will build a *-app.jar file like it used to. As usual
there is only a 100% opaque maven pom to look at, so I have not the slightest clue why the
-app.jar file isn't being built. Have I mentioned how much I hate !#@$@% maven. I tried an
explicit "mvn assembly:assembly" as used to work in earlier versions but not joy there either.


At any rate, I have no idea where to go to from here...

Thanks
  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message