directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: [Studio] Issues with Eclipse 3.4
Date Wed, 01 Oct 2008 07:42:24 GMT
On Tue, Sep 30, 2008 at 11:45 PM, Stefan Seelmann <seelmann@apache.org>wrote:

> - Open the LDAP Search dialog
> - (make sure the filter combo box contains some filters)
> - In the filter field type in a "t", a popup with some proposals appears
> - Press key-down
>
> With Eclipse 3.3 the cursor in the popup moves down and you are able to
> select one proposed attribute
>
> With Eclise 3.4 the popup is closed and an older filter from the combo
> box is selected.
>

Thanks Stefan, I was able to reproduce it.
That sucks a little... :(

It looks like the "KeyListener" of the Combo has a higher priority than the
one for the content assist...

What can we do about it ?



> > I couldn't reproduce this with the latest trunk on Mac OS X, nor Ubuntu.
>
> It's fixed.
>

Cool... :)



> > I've just tested this with the latest trunk and I was able to launch the
> > application successfully on Windows.
> > Could you try again and tell me if the problem still occurs in your
> > environment please ?
>
> Yes, it still occurs. I run "mvn clean install" and then tried to start
> "target\distributions\ApacheDirectoryStudio-win32-1.3.0-SNAPSHOT\Apache
> Directory Studio.exe"


That's insane...
We have the same environment Windows XP SP3 as a VM and it works for me and
not for you...
There's something I don't understand...

If anyone could test it too on his Windows machine, it would be a great
help.
Thanks.

BTW, I also noticed another bug with Eclipse 3.4 dependencies. The "Help"
balloon ("?") icon seems to be missing and we get a red square instead. This
can be viewed in Wizards for example. Maybe I removed too much lines in the
plugin.xml files of our modified Eclipse plugins.

Regards,
Pierre-Arnaud

Mime
View raw message