directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [Studio] What's the better approch to move to Apache DS 1.5.4 in the Apache DS plugin?
Date Thu, 18 Sep 2008 12:04:21 GMT
Pierre-Arnaud Marcelot wrote:
> 
> In each of the these solutions, the Apache DS plugin will need package
> in its dependencies the jars of version 1.5.3 AND 1.5.4 (something
> around 17 MB).

I think that is not easy. If we package all jars into *one* apacheds
plugin we will enter the class loading hell. How is this solved in WTP?
There it is also possible to create instances of different Tomcat versions.

> I think solution one is easiest and safest solution to preserve the data
> from the server. If a user wants to move to version 1.5.4, he can create
> a new server and then migrate his data from the old server to the new one.

+1. I think this is the simplest solution.


Another point: We should consider to release the Server jars as OSGi
bundles to make it possible to just put them into the Studio/Eclipse
plugins folder.

Regards,
Stefan



Mime
View raw message