directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [Studio] Updatesite
Date Thu, 04 Sep 2008 14:04:12 GMT
Pierre-Arnaud Marcelot wrote:
> The plugins will still run with Eclipse 3.3. Our plugins still use the
> 3.3.x API.
> 
> The Eclipse 3.4 dependencies are only used in the final RCP application
> as they are bundled in it (, and also for Maven compilation) .
> 
> So I think, its ok and there's no need to change the update site.
> 
> We just need to take care to not be using any new features provided in
> the 3.4 API that we can't find in the 3.3.x API.
> 

I agree, lets continue to support 3.3 for a while. I think many users
out there still use Eclipse 3.3 (e.g. those who use a commercial Eclipse
IDE).

Its easy to manage this. Even if we use Eclipse 3.4 for development we
could define an 3.3 as target environment, this way we only see the 3.3 API.

However if we find a new killer feature in 3.4 we could switch :-)

Kind regards,
Stefan

Mime
View raw message