directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Pb building Studio from scratch, missing artifact
Date Fri, 29 Aug 2008 17:50:40 GMT
Hi guys,

while trying to fix the bug I introduced lately with my modification in 
shared, I found that it was not possible to run mvn eclipse:eclipse on 
studio, because of the missing studio-dsml-parser jar.

There must be something wrong in the way we declare the dependencies or 
the build order. Does enyone has an idea ?

Here are the logs I get  (Pierre-Arnaud confirmed that he has the same 
problem) :

[INFO] 
------------------------------------------------------------------------
[INFO] Building Apache Directory Studio Jars
[INFO]    task-segment: [eclipse:eclipse]
[INFO] 
------------------------------------------------------------------------
[INFO] Preparing eclipse:eclipse
Downloading: 
http://repo1.maven.org/maven2/org/apache/directory/studio/studio-dsml-parser/0.4.2/studio-dsml-parser-0.4.2.jar
[INFO] 
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] 
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.apache.directory.studio:studio-dsml-parser:jar:0.4.2

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=org.apache.directory.studio 
-DartifactId=studio-dsml-parser -Dversion=0.4.2 -Dpackaging=jar 
-Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file 
there:
      mvn deploy:deploy-file -DgroupId=org.apache.directory.studio 
-DartifactId=studio-dsml-parser -Dversion=0.4.2 -Dpackaging=jar 
-Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency:
      1) org.apache.directory.studio:jars:jar:1.3.0.SNAPSHOT
      2) org.apache.directory.studio:studio-dsml-parser:jar:0.4.2

----------
1 required artifact is missing.

for artifact:
  org.apache.directory.studio:jars:jar:1.3.0.SNAPSHOT

from the specified remote repositories:
  central (http://repo1.maven.org/maven2),
  apache.directory.snapshot.repo (http://vm094.oxylos.org/mirror-maven2/),
  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository)


[INFO] 
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] 
------------------------------------------------------------------------
[INFO] Total time: 17 seconds
[INFO] Finished at: Fri Aug 29 17:50:56 CEST 2008
[INFO] Final Memory: 28M/120M

-- 
--
cordialement, regards,
Emmanuel L├ęcharny
www.iktek.com
directory.apache.org



Mime
View raw message