This could be a solution, but I think this will be a problem when we try the plugins (Run and Debug) within Eclipse, as the placeholder will not be replaced by its value...

WDYT ?

Pierre-Arnaud

On Wed, Jun 11, 2008 at 3:19 PM, Felix Knecht <felixk@apache.org> wrote:
Felix Knecht schrieb:
Pierre-Arnaud Marcelot schrieb:
 Hi Felix,

 Actually, it would be better if we don't change the version number on
this project.
 It is used and bundled in the Apache DS plugin, and the version is
hardcoded in the coded of the plugin (sorry but it was needed and I had no other solution)...

Is it in the apacheds/.../ApacheDsPluginUtils.java?

What about reading this things
- String APACHEDS_VERSION = "1.5.2"
- String[] apachedsLibraries
from a properties file located somewhere in the resource folder and having the resource file filtered with the wanted version?

It's not even needed to have a properties file, it can even be done in the java source file, see
http://www.gxdeveloperweb.com/Blogs/Bram-de-Kruijff/Maven-secrets-filtering-sources.htm

Felix