directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: [Studio] Framework for Integration Tests
Date Mon, 09 Jun 2008 11:32:11 GMT
Hi Stefan,

I'm getting an error, when I try to launch the integration core tests on my
Mac:
-------------------------------------------------------
 T E S T S
-------------------------------------------------------
There are no tests to run.

Results :

Tests run: 0, Failures: 0, Errors: 0, Skipped: 0

[INFO] [antrun:run {execution: integration-ui}]
[INFO] Executing tasks
   [delete] Deleting directory
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox
    [mkdir] Created dir:
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox
    [mkdir] Created dir:
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox/workspace
     [copy] Copying 752 files to
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox
     [copy] Copying 16 files to
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox/plugins
     [copy] Copying 1 file to
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox/plugins
     [copy] Copying 380 files to
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox/plugins
     [copy] Copied 54 empty directories to 5 empty directories under
/Users/pajbam/Development/Apache/Studio/test-integration-core/target/test-sandbox/plugins
     [java] Exception in thread "main" java.lang.NoClassDefFoundError:
org/eclipse/core/launcher/Main
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error executing ant tasks

Embedded error: Java returned: 1
[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 2 minutes 5 seconds
[INFO] Finished at: Mon Jun 09 13:20:30 CEST 2008
[INFO] Final Memory: 44M/63M
[INFO]
------------------------------------------------------------------------

I'll try to see why it's failing.

Regards,
Pierre-Arnaud

On Mon, Jun 9, 2008 at 11:40 AM, Pierre-Arnaud Marcelot <pa@marcelot.net>
wrote:

> Hi Stefan,
>
> This looks very slick!!!
>
> I'm going to test that...
>
> Thanks a lot,
> Pierre-Arnaud
>
>
> On Sun, Jun 8, 2008 at 3:07 PM, Stefan Seelmann <seelmann@apache.org>
> wrote:
>
>> Hi,
>>
>> here is an update.
>>
>> I finished the integration testing framework for Studio and I'm going to
>> merge it into trunk soon.
>>
>> How to use it:
>>
>> 1)
>> Building Studio with maven from command line works like before, there is
>> no change to the current process.
>>
>> 2)
>> To run the integration test with maven from command line you need a
>> local installation of Eclipse and to set a eclipse-home property that
>> points to the Eclipse installation path, see [1]
>>
>> Then the tests could be started with
>> - Core tests only:   mvn -Pintegration-core test
>> - UI tests only:     mvn -Pintegration-ui test
>> - Core and UI tests: mvn -Pintegration-core,integration-ui test
>>
>> When running the tests all relevant plugins are copied from different
>> locations to the "test-sandbox":
>> - from a previous "mvn install" the complete Studio distribution
>> - from the resource folder the SWTBot plugins
>> - the test-integration-[core|ui] plugin itself
>> - some additional plugins from the local eclipse installation
>> Then the tests are lauched.
>>
>> 3)
>> For development you need to install the SWTBot plugins because the
>> test-integration-ui plugin depends on the SWTBot plugins [2]. I added
>> two launch configurations that could be used to launch the tests within
>> Eclipse.
>>
>>
>> The next step is to create some more tests :-)
>>
>>
>> Kind Regards,
>> Stefan
>>
>>
>> [1] http://directory.apache.org/studio/building.html
>> [2] http://directory.apache.org/studio/working.html
>>
>>
>> Stefan Seelmann wrote:
>> > Hi Dev,
>> >
>> > I am working on a framework for integration tests for studio. I added
>> > two plugins into my sandbox, one for core and one for UI tests.
>> >
>> >
>> > Core Integration Tests
>> > ----------------------
>> >
>> > The core tests don't depend on any UI code, but on the Eclipse runtime.
>> > So it is necessary to startup Eclipse in headless mode, then it is
>> > possible to access things like Jobs, Preferences, etc.
>> >
>> > It is already possible to run these test within eclipse or from maven.
>> > However in the maven pom there are some fixed paths, I need to remove
>> > them, maybe I need some help from a maven guru.
>> >
>> >
>> > UI Integration Tests
>> > --------------------
>> >
>> > For UI test I selected SWTBot (http://www.swtbot.org). There are still
>> > some features missing in the current version 0.2, but it looks very
>> > stable and the API is very easy to use. An UI-Recorder is under
>> > development. Last not least it is licenced under ASLv2.
>> >
>> > Here is an example how a test looks like: http://tinyurl.com/3j5ujs
>> > It opens the New Connection wizard, enters all connection parameters,
>> > does some checks and closes the connection.
>> >
>> > There are some open issues:
>> >
>> > 1) We have to extend SWTBot, I already contacted the author that I am
>> > interested in contributing.
>> >
>> > 2) SWTBot depends on many Eclipse plugins. To run the tests from maven
>> > we need to add about 50MB of plugins to our repository. Atm I just have
>> > a tarball containing all these plugins, but I don't want to commit them
>> > to svn.
>> >
>> >
>> > I'll keep you informed.
>> >
>> >
>> > Kind Regards,
>> > Stefan Seelmann
>>
>>
>>
>

Mime
View raw message