directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Quality is dropping? (was: Fwd: Adding indices on 1.5.2)
Date Wed, 07 May 2008 13:20:15 GMT
How did we slip up like this? Any idea?

This user just got a really bad taste of ADS.

Alex


---------- Forwarded message ----------
From: Alex Karasulu <akarasulu@apache.org>
Date: Wed, May 7, 2008 at 9:02 AM
Subject: Re: Adding indices on 1.5.2
To: users@directory.apache.org


I'm really sorry about this but there presently is no way after starting the
server to add a new index :(.  The only option at this point is to build the
indices you need before starting the server and reload your data.

This is due to the fact that the changes made with the latest installer
layout and the introduction of instances were not reflected in these tools.
What that means is the tools are looking in the wrong place for the
partition data.  This will hopefully be fixed in 1.5.3.

Sorry about it,
Alex


On Wed, May 7, 2008 at 5:30 AM, joachim <joachim@netenviron.com> wrote:

> I tried to add an index on a partition called community on a new attribute
> using this command
>
> java -jar apacheds-tools.jar index -i /usr/local/apacheds-1.5.2/ -p
> community -a epdstatus
>
> Result:
>
>       _                     _          ____  ____    _____           _
>      / \   _ __   __ _  ___| |__   ___|  _ \/ ___|  |_   _|__   ___ | |___
>     / _ \ | '_ \ / _` |/ __| '_ \ / _ \ | | \___ \    | |/ _ \ / _ \| /
> __|
>    / ___ \| |_) | (_| | (__| | | |  __/ |_| |___) |   | | (_) | (_) | \__
> \
>   /_/   \_\ .__/ \__,_|\___|_| |_|\___|____/|____/    |_|\___/
> \___/|_|___/
>           |_|
>
> loading settings from: /usr/local/apacheds-1.5.2/conf/server.xml
> log4j:WARN No appenders could be found for logger
> (org.apache.xbean.spring.context.FileSystemXmlApplicationContext).
> log4j:WARN Please initialize the log4j system properly.
> Exception in thread "main"
> org.apache.directory.shared.ldap.exception.LdapConfigurationException: The
> following schema directory from the installation layout could not be found:
>        /usr/local/apacheds-1.5.2/var/partitions/schema
>        at
> org.apache.directory.server.tools.IndexCommand.loadRegistries(IndexCommand.java:131)
>        at
> org.apache.directory.server.tools.IndexCommand.execute(IndexCommand.java:184)
>        at
> org.apache.directory.server.tools.ApachedsTools.main(ApachedsTools.java:116)
>
>
> 1. Why does it need conf/server.xml? I asumed
>  /instances/community/conf/server.xml should be the one?
> 2. I have not changed any installation layout, /var/partitions is empty
> 3. Documentation is not updated yet, but is there a way to add indices on
> 1.5.2?
>
> thx,
> Joachim
>

Mime
View raw message