Hi felix,

All of them.

I'm done with the sandbox now, I will delete it soon, so you can forget about it ;)

Regards,
Pierre-Arnaud

On Wed, Apr 2, 2008 at 10:34 AM, Felix Knecht <felixk@apache.org> wrote:
Pierre-Arnaud Marcelot schrieb:

Hi David,

You can generate the server installers using the following command:
$ mvn clean install -Pserver-installer

from trunk, bigbang or sandbox?

Felix

We also have a profile for Studio installer (which is almost no longer used) and a profile for the Suite (Server+Studio) installer.

HTH,
Pierre-Arnaud

On Wed, Apr 2, 2008 at 9:51 AM, David Jencks <david_jencks@yahoo.com <mailto:david_jencks@yahoo.com>> wrote:

   And, I still have no idea how to test the installers.... so if
   something breaks please let me know

   thanks
   david jencks


   On Apr 2, 2008, at 12:50 AM, David Jencks wrote:

       I've committed these changes

       project rev 643768
       shared rev 643769
       apacheds rev 643775
       installers rev 643776,643777

       Installers are not quite done.  I've supplied the root LICENSE
       and NOTICE files and appended-resources/META-INF/LICENSE and
       NOTICE files for apacheds-noarch but I don't understand how
       the apacheds-installers project works.  If it could be
       arranged to reuse the jar assembled in noarch that would seem
       ideal to me.  If the same jars are included in the installers
       as in noarch the generated LICENSE and NOTICE files from
       noarch should be fine to include in the other installers.

       I can't determine the spring copyright (years or holder)  We
       should try harder to fix this before release.

       There's a bit of cruft left in the noarch module.

       I still think that including the entire bouncycastle jar is
       risky at best.  i think it would be a good idea to check that
       java 5 doesn't supply the needed functions and if not consider
       extracting just the files needed for the specific uses we have
       in mind.


       thanks
       david jencks

       On Apr 1, 2008, at 5:29 PM, David Jencks wrote:

           I talked with alex and elecharny a bit earlier today and
           we think we can simplify the build a bit.

           I expected to be done with it by now but learning about
           the installers took longer than I expected.

           Here is my work so far: it might be complete as far as the
           build goes.  I expect to finish it later tonight but have
           to go out for a while now.

           It requires maven 2.0.8

           <project.diff>
           <shared.diff>
           <apacheds.diff>
           <installers.diff>

           thanks
           david jencks