directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: [ApacheDS] RPM build failure on Fedora 8
Date Thu, 17 Apr 2008 00:14:12 GMT
CentOS works for me and that's why I have placed less stress on this issue.

BTW could you look at the thread concerning instances and apacheds-tools
functionality? Interested in what you might have done in the past to deal
with this issue so we can figure out the best way forward with a solution.

Thanks,
Alex

On Wed, Apr 16, 2008 at 7:38 PM, Chris Custine <ccustine@apache.org> wrote:

> This is a real problem caused by a change to rpmbuild *after* Fedora 8 was
> released.  This update came sometime in October as best I can tell and it
> was really frustrating trying to figure it out.
>
> Here is a related issue (I have seen a few others as well), but from what
> I can tell the Fedora guys want it to stay this way.
> https://bugzilla.redhat.com/show_bug.cgi?id=406001
>
> I am sure some rpm ninja could figure out a work around, but I haven't
> quote been able to figure out the solution either.  I have just been
> building on CentOS in the mean time.
>
> If I run across a workaround I will try it out.
>
> Chris
>
>
> On Wed, Apr 16, 2008 at 5:08 PM, Alex Karasulu <akarasulu@apache.org>
> wrote:
>
> > Hi PAM,
> >
> > I got this interesting error just now while trying to build the
> > installers from the release on a Fedora Core 8 machine.  This is a i386
> > machine so I was trying to generate the i386 RPM.  I'm not stuck or anything
> > but I thought I'd point out the problem in case we see it regularly.  Here's
> > the command I ran in the installers/apacheds module:
> >
> >     mvn clean install -Pserver-installer
> >
> > Here's the odd error message I got while the RPM build process was
> > underway:
> >
> > *** ERROR: No build ID note found in
> > /var/tmp/apacheds-1.5.2-0-root/opt/apacheds-1.5.2/bin/apacheds
> > error: Bad exit status from /var/tmp/rpm-tmp.13280 (%install)
> >     Bad exit status from /var/tmp/rpm-tmp.13280 (%install)
> >
> >
> > RPM build errors:
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] BUILD FAILURE
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Execution of ' /usr/bin/rpmbuild -ba --define _topdir
> > /home/akarasulu/1.5.2-with-dependencies/installers/apacheds/target/rpmbuild
> > /home/akarasulu/1.5.2-with-dependencies/installers/apacheds/target/images/apacheds-i386-rpm.spec
> > ' resulted in a non-zero exit value: 1
> >
> > This a fluke or you think I should put it into JIRA?
> >
> > Thanks,
> > Alex
> >
>
>

Mime
View raw message