directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Why are we now downloading source packages when building the sources ?
Date Sat, 05 Apr 2008 16:32:02 GMT
I'm not sure exactly what you are seeing, but since we started using  
xbean the build requires the source jars of the modules with the  
components in them.

I can think of 2 recent changes that might affect this....
- build changes for 1.5.2 release
- new CI server that pushes snapshots frequently.

Also maybe there's a new maven eclipse plugin that has different  
behavior?

I have no actual idea what might have caused this change, but I don't  
think its needing source jars in the build since they have been  
required for a long time.

thanks
david jencks

On Apr 5, 2008, at 1:10 AM, Emmanuel Lecharny wrote:

> Hi guys,
>
> it's now a couple of days I see that when I try to build the  
> project, a hell lot of dowloads are done. Typically, when doing a  
> mvn eclipse:eclipse twice, it takes around 3 minutes when it was  
> just a matter of 20 seconds before.
>
> There is something wrong here. I don't care getting the jars at  
> all, because maven is smart enough (yes !) to be able to point to  
> projects in .classpath instead of source jars.
>
> Can we please get back to what we had (no sources download)?
>
> Thanks a lot !
>
> -- 
> --
> cordialement, regards,
> Emmanuel L├ęcharny
> www.iktek.com
> directory.apache.org
>
>


Mime
View raw message