directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Montag" <davmo...@student.liu.se>
Subject Re: [ApacheDS] [Urgent] Running Apache DS with an 'apacheds' user ?
Date Mon, 31 Mar 2008 12:26:12 GMT
Hi,

When I tried using an installer, I had to enter the apacheds user's password
when starting the server using /etc/init.d/apacheds start default. Maybe
this is more or less what Felix said?

/David

On Mon, Mar 31, 2008 at 2:05 PM, Felix Knecht <felixk@apache.org> wrote:

> Pierre-Arnaud Marcelot schrieb:
> > Hi,
> >
> > I'm trying to finish the new installers (.deb and .bin), and I'm
> > facing an issue when I'm trying to run Apache DS with an 'apacheds'
> user.
> >
> > I looked at the RPM Spec file
> > (/installers/apacheds/src/main/installers/apacheds-rpm.spec) used to
> > build the RPM package and I've seen that it creates a group and a user
> > called 'apacheds' on the target system and that the init script uses
> > this 'apacheds' user to run the server.
> >
> > I added the same thing in the .deb and .bin installer. The user and
> > group 'apacheds' are well created but launching the server does not
> > work as expected, letting me with no log in the wrapper, nor the server.
> >
> > If anyone has an idea...
> Maybe this helps to get more error messages:
>
> Try after installation to sudo su - apacheds and start the server
> manually (not from the /etc/init.d script but what the script does.
>
> I could imaging missing permissions on files or missing $JAVA_HOME or so
> ....
>
> Felix
>
> > Chris maybe, as you designed the RPM Spec.
> >
> > Thanks,
> > Pierre-Arnaud
>
>

Mime
View raw message