+1

On Feb 1, 2008 2:28 PM, Stefan Seelmann <seelmann@apache.org> wrote:
+1, feel free to rename it.

I also checked that we don't use this class in Studio atm.


Emmanuel Lecharny schrieb:
> Hi,
>
> I'm just wondering if it would not be a good idea to rename the
> org.apache.directory.shared.ldap.ldif.Entry class to
> org.apache.directory.shared.ldap.ldif.LdifEntry ?
>
> This is a littler bit embarrassing to have so many classes named Entry !
>
> org.apache.directory.shared.ldap.ldif.Entry
> org.apache.directory.server.core.interceptor.InterceptorChain$Entry
> org.apache.directory.shared.ldap.aci.ProtectedItem$Entry
> org.apache.directory.shared.ldap.entry.Entry<T>
>
> I personaly don't like the interceptor Entry name (Item or Element fits
> me better)
>
> Wdyt ?
>