directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: [Studio] Mavenization status - Remaning issues
Date Wed, 06 Feb 2008 14:09:25 GMT
The repository is up!

On Feb 6, 2008 1:52 PM, Pierre-Arnaud Marcelot <pa@marcelot.net> wrote:

> No pb... ;)
>
> These were useful commits. I very like the update site generation. :)
> Everything is now configured from the root pom.xml.
> Thanks.
>
> Pierre-Arnaud
>
>
> On Feb 6, 2008 1:42 PM, Felix Knecht <felixk@apache.org> wrote:
>
> > Pierre-Arnaud Marcelot schrieb:
> > > S***t, commit failed. Some modifications on the root pom.xml have
> > > probably made it fail.
> >
> > Sorry, this was me for sure. I don't do any commits so until yours are
> > up.
> >
> > >
> > >     svn: Commit failed (details follow):
> > >     svn: MERGE request failed on
> > >     '/repos/asf/directory/studio/branches/studio-maven'
> > >     svn: Conflict at '/directory/studio/branches/studio-maven'
> > >
> > >
> > > Re-commiting... ;)
> > >
> > > On Feb 6, 2008 1:26 PM, Pierre-Arnaud Marcelot <pa@marcelot.net
> > > <mailto:pa@marcelot.net>> wrote:
> > >
> > >     Still committing the repository module...
> > >
> > >     Dependencies take time to upload...
> > >
> > >     Pierre-Arnaud
> > >
> > >
> > >     On Feb 6, 2008 12:31 PM, Pierre-Arnaud Marcelot <pa@marcelot.net
> > >     <mailto:pa@marcelot.net>> wrote:
> > >
> > >         I'm going to check-in the repository.
> > >
> > >         I found that the org.apache.jasper plugins is a dependency of
> > >         org.eclipse.help.webapp.
> > >
> > >         Pierre-Arnaud
> > >
> > >
> > >         On Feb 6, 2008 12:25 PM, Felix Knecht <felixk@apache.org
> > >         <mailto:felixk@apache.org>> wrote:
> > >
> > >             Pierre-Arnaud Marcelot schrieb:
> > >             > Thanks.
> > >             >
> > >             > I tried to create the repository but I got an error when
> > >             retrieving
> > >             > the dependencies:
> > >             > MacBook-Pro:repository pajbam$ mvn clean install
> > >             > [INFO] Scanning for projects...
> > >             > [INFO]
> > >             >
> > >
> > ------------------------------------------------------------------------
> > >             > [INFO] Building Apache Directory Studio Repository
> > >             > [INFO]    task-segment: [clean, install]
> > >             > [INFO]
> > >             >
> > >
> > ------------------------------------------------------------------------
> > >             > [INFO] [clean:clean]
> > >             > [INFO] Deleting directory
> > >             >
> > >
> > /Users/pajbam/Development/Apache/studio-maven/repository/target
> > >             > [INFO] Deleting directory
> > >             >
> > >
> > /Users/pajbam/Development/Apache/studio-maven/repository/target/classes
> > >             > [INFO] Deleting directory
> > >             >
> > >
> > /Users/pajbam/Development/Apache/studio-maven/repository/target/test-classes
> > >             > [INFO] Deleting directory
> > >             >
> > >
> > /Users/pajbam/Development/Apache/studio-maven/repository/target/site
> > >             > [INFO]
> > >             >
> > >
> > ------------------------------------------------------------------------
> > >             > [ERROR] BUILD ERROR
> > >             > [INFO]
> > >             >
> > >
> > ------------------------------------------------------------------------
> > >             > [INFO] Failed to resolve artifact.
> > >             >
> > >             > Couldn't find a version in [5.5.17.v200706111724] to
> > >             match range [0,4.0.0)
> > >             >   org.apache:jasper:jar:null
> > >             >
> > >             > from the specified remote repositories:
> > >             >   central (http://repo1.maven.org/maven2),
> > >             >   apache.snapshots
> > >             (http://people.apache.org/repo/m2-snapshot-repository),
> > >             >   studio.repository
> > >             >
> > >
> > (file:///Users/pajbam/Development/Apache/studio-maven/repository),
> > >             >   maven.repo1 (http://repo1.maven.org/maven2)
> > >             >
> > >             >
> > >             > [INFO]
> > >             >
> > >
> > ------------------------------------------------------------------------
> > >             > [INFO] For more information, run Maven with the -e
> > switch
> > >             > [INFO]
> > >             >
> > >
> > ------------------------------------------------------------------------
> > >             > [INFO] Total time: 2 seconds
> > >             > [INFO] Finished at: Wed Feb 06 11:33:06 CET 2008
> > >             > [INFO] Final Memory: 6M/11M
> > >             > [INFO]
> > >             >
> > >
> > ------------------------------------------------------------------------
> > >             >
> > >             > Strangely, it does not occur when we're using the
> > >             people.apache.org <http://people.apache.org>
> > >             > <http://people.apache.org> repo.
> > >             > Do you know where it could come from ?
> > >             >
> > >
> > >             No, I don't have any idea. Can you please checkin the
> > >             module? Maybe I
> > >             can find it out this way. I can't remember any eclipse
> > >             dependency using
> > >             jasper. Can this be a problem of parent pom 8?
> > >
> > >             Felix
> > >
> > >
> > >
> > >
> >
> >
>

Mime
View raw message