directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Knecht <fel...@apache.org>
Subject Re: [Studio] Mavenization status - Remaning issues
Date Wed, 06 Feb 2008 11:25:10 GMT
Pierre-Arnaud Marcelot schrieb:
> Thanks.
>
> I tried to create the repository but I got an error when retrieving 
> the dependencies:
> MacBook-Pro:repository pajbam$ mvn clean install
> [INFO] Scanning for projects...
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Building Apache Directory Studio Repository
> [INFO]    task-segment: [clean, install]
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] [clean:clean]
> [INFO] Deleting directory 
> /Users/pajbam/Development/Apache/studio-maven/repository/target
> [INFO] Deleting directory 
> /Users/pajbam/Development/Apache/studio-maven/repository/target/classes
> [INFO] Deleting directory 
> /Users/pajbam/Development/Apache/studio-maven/repository/target/test-classes
> [INFO] Deleting directory 
> /Users/pajbam/Development/Apache/studio-maven/repository/target/site
> [INFO] 
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
>
> Couldn't find a version in [5.5.17.v200706111724] to match range [0,4.0.0)
>   org.apache:jasper:jar:null
>
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>   studio.repository 
> (file:///Users/pajbam/Development/Apache/studio-maven/repository),
>   maven.repo1 (http://repo1.maven.org/maven2)
>
>
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Total time: 2 seconds
> [INFO] Finished at: Wed Feb 06 11:33:06 CET 2008
> [INFO] Final Memory: 6M/11M
> [INFO] 
> ------------------------------------------------------------------------
>
> Strangely, it does not occur when we're using the people.apache.org 
> <http://people.apache.org> repo.
> Do you know where it could come from ?
>

No, I don't have any idea. Can you please checkin the module? Maybe I 
can find it out this way. I can't remember any eclipse dependency using 
jasper. Can this be a problem of parent pom 8?

Felix


Mime
View raw message