directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: [Studio] Mavenization status - Remaning issues
Date Thu, 31 Jan 2008 22:25:54 GMT
Ok, I found out what it was...

I was wrong, it was getting the plugin from another maven repository... I
did not changed the version number of the new uploaded dependencies.

The build now works well on Windows and Linux... but I still have a strange
issue on Mac OS X (eveything was working until I dropped my .m2 folder)...

Here's the output of 'mvn clean install -Pnotests,macosx':
[INFO]
------------------------------------------------------------------------
[INFO] Building Apache Directory Studio Build
[INFO]    task-segment: [clean, install]
[INFO]
------------------------------------------------------------------------
[INFO] [clean:clean]
[INFO] Deleting directory
/Users/pajbam/Development/Apache/studio-maven/studio/target
[INFO] Deleting directory
/Users/pajbam/Development/Apache/studio-maven/studio/target/classes
[INFO] Deleting directory
/Users/pajbam/Development/Apache/studio-maven/studio/target/test-classes
[INFO] Deleting directory
/Users/pajbam/Development/Apache/studio-maven/studio/target/site
[INFO] [remote-resources:process {execution: default}]
[INFO] [dependency:unpack {execution: launcher-macosx (unpack)}]
[INFO] Configured Artifact:
org.apache.directory.studio:launcher-macosx:?:tar.gz
[INFO] Configured Artifact:
org.eclipse.equinox.launcher.carbon:macosx:?:tar.gz
[INFO] Unpacking
/Users/pajbam/.m2/repository/org/apache/directory/studio/launcher-macosx/1.1.0/launcher-
macosx-1.1.0.tar.gzto
 /Users/pajbam/Development/Apache/studio-maven/studio/target/ApacheDirectoryStudio-macosx
with Includes null and excludes:null
[INFO] Expanding
/Users/pajbam/.m2/repository/org/apache/directory/studio/launcher-macosx/1.1.0/launcher-
macosx-1.1.0.tar.gz to /tmp/tmp29092.tar
[INFO] Expanding: /tmp/tmp29092.tar into
/Users/pajbam/Development/Apache/studio-maven/studio/target/ApacheDirectoryStudio-macosx
[WARNING] -------------------------------
[WARNING] Standard error:
[WARNING] -------------------------------
[WARNING]
[WARNING] -------------------------------
[WARNING] Standard output:
[WARNING] -------------------------------
[WARNING] /bin/sh: line 0: cd:
/Users/pajbam/Development/Apache/studio-maven/studio/target/ApacheDirectoryStudio-macosx/Apache:
No such file or directory

[WARNING] -------------------------------
org.codehaus.plexus.archiver.ArchiverException: chmod exit code was: 1
    at org.codehaus.plexus.archiver.util.ArchiveEntryUtils.chmod(
ArchiveEntryUtils.java:59)
    at org.codehaus.plexus.archiver.zip.AbstractZipUnArchiver.extractFile(
AbstractZipUnArchiver.java:236)
    at org.codehaus.plexus.archiver.tar.TarUnArchiver.execute(
TarUnArchiver.java:92)
    at org.codehaus.plexus.archiver.tar.TarGZipUnArchiver.execute(
TarGZipUnArchiver.java:76)
    at org.codehaus.plexus.archiver.AbstractUnArchiver.extract(
AbstractUnArchiver.java:108)
    at org.apache.maven.plugin.dependency.AbstractDependencyMojo.unpack(
AbstractDependencyMojo.java:266)
    at
org.apache.maven.plugin.dependency.fromConfiguration.UnpackMojo.unpackArtifact
(UnpackMojo.java:122)
    at
org.apache.maven.plugin.dependency.fromConfiguration.UnpackMojo.execute(
UnpackMojo.java:95)
    at org.apache.maven.plugin.DefaultPluginManager.executeMojo(
DefaultPluginManager.java:447)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(
DefaultLifecycleExecutor.java:539)
    at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle
(DefaultLifecycleExecutor.java:480)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(
DefaultLifecycleExecutor.java:459)
    at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures
(DefaultLifecycleExecutor.java:311)
    at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(
DefaultLifecycleExecutor.java:278)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(
DefaultLifecycleExecutor.java:143)
    at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
    at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
    at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
    at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
    at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
    at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error unpacking file:
/Users/pajbam/.m2/repository/org/apache/directory/studio/launcher-macosx/1.1.0/launcher-
macosx-1.1.0.tar.gz to:
/Users/pajbam/Development/Apache/studio-maven/studio/target/ApacheDirectoryStudio-macosx
org.codehaus.plexus.archiver.ArchiverException: chmod exit code was: 1

[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 2 minutes 48 seconds
[INFO] Finished at: Thu Jan 31 23:21:01 CET 2008
[INFO] Final Memory: 33M/63M
[INFO]
------------------------------------------------------------------------

Am I the only to have this issue?

Thanks,
Pierre-Arnaud

On Jan 31, 2008 5:52 PM, Pierre-Arnaud Marcelot <pa@marcelot.net> wrote:

> Hehe.
>
> There are no silly questions... ;)
>
> This is the same URL, I saw it on the maven log... I'm not behind any
> proxy. That's really really strange...
>
> I'm currently running a complete refresh of the entire m2 repo (I only
> dropped the eclipse sub-directory in my tries). I hope it will fix it...
>
> Pierre-Arnaud
>
>
> On Jan 31, 2008 5:44 PM, Felix Knecht <felixk@apache.org> wrote:
>
> > Pierre-Arnaud Marcelot schrieb:
> > > Hi Felix,
> > >
> > > That's good. Thanks. I just had to modify one line in the pom.
> > >
> > > But I have a strange issue... Even if I clean my local m2 repo, the
> > jar
> > > that get copied by maven from our repo does not have the same checksum
> > > as the one I can download using Firefox on the same url...
> > > Maybe there are some mirror update problems...
> >
> > Sorry for silly questions, but are you sure maven downloads it from
> > 'our' repository (you can see the url during the
> > build process) or are you behind a proxy and the file has the same name?
> >
> > As said, just ideas and silly questions....
> >
> > Felix
> >
>
>

Mime
View raw message