directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: [Studio] Mavenization status - Remaning issues
Date Tue, 29 Jan 2008 13:12:17 GMT
Hi Felix,

Thanks for the updates but they still don't comply with the verification.
The 'org.eclipse.core.runtime.compatibility.registry' jar seems almost
empty, with only the META-INF folder and the MANIFEST.MF file in it
(although this file seems intact this time).
The 'org.eclipse.ui.workbench.compatibility' jar does not seem very well
packaged. When I open it here's the structure I see:
/
|-- META-INF/
   |-- MANIFEST.MF
|-- org.eclipse.ui.workbench.compatibility/
   |-- META-INF/
      |-- MANIFEST.MF
   |-- about.html
   |-- compatibiliy.jar
   |-- fragments-compatibility.properties

About the missing plugins, strangely they are needed on Mac OS X to start
the application, which makes me think they are not necessary on Linux too...
I don't know why the launcher complains on Linux... Maybe there's another
dependency causing this issue.
I'll see if I can find what's going on...

Thanks,
Pierre-Arnaud

On Jan 25, 2008 12:44 PM, Felix Knecht <felixk@apache.org> wrote:

> Pierre-Arnaud Marcelot schrieb:
> >
> > 2°/ We have some problems with the MANIFEST.MF files of the
> > "org.eclipse.ui.workbench.compatibility" and
> > "org.eclipse.core.runtime.compatibility.registry" plugins.
> > The SHA1 checksum verification fails on these files. It seems a line
> > has been added " Archiver-Version: Plexus Archiver".
> > Can we do something about that and use the original MANIFEST.MF files,
> > Felix ?
> I uploaded the the jars to p.a.o/~felixk/...
> After that the log told me that there were still some plugins missing
> which I added in my latest commit.
>
> Felix
>
>

Mime
View raw message