directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSTUDIO-269) Attributes not displayed when browsing BEA Weblogic embedded LDAP
Date Thu, 24 Jan 2008 22:11:34 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-269?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12562250#action_12562250
] 

Stefan Seelmann commented on DIRSTUDIO-269:
-------------------------------------------

I made some test with en BEA embedded LDAP, it seems it isn't fufill the LDAP specs ;-)

When browsing in Studio we are requesting the following attributes: "* objectClass" or "*
+"

According to RFC 4511 section 4.5.1.8. these are correct request:
------------------------------------------------------------------------------------------
      2. A list containing "*" (with zero or more attribute
         descriptions) requests the return of all user attributes in
         addition to other listed (operational) attributes.
 ------------------------------------------------------------------------------------------

However the BEA embedded LDAP only returns all attributes if only "*" is requested. 

If "* objectClass" is requested it doesn't note the "*" but only "objectClass". We could optimize
that request, it is enought to just ask for "*".

The other request "* +" is used to retrieve user attributes as well as operational attributes
if the option "Show operational attributes" is enabled. We could also optimize that request,
we should only send the "+" if the server supports this feature (supportedFeatures=1.3.6.1.4.1.4203.1.5.1).


> Attributes not displayed when browsing BEA Weblogic embedded LDAP
> -----------------------------------------------------------------
>
>                 Key: DIRSTUDIO-269
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-269
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-ldapbrowser
>    Affects Versions: 1.0.1
>         Environment: BEA Weblogic 8.1 embedded LDAP 
>            Reporter: Nicholas Makin
>            Priority: Minor
>             Fix For: 1.1.0
>
>
> The LDAP browser will not display attributes for anything but the root DSE. Searches
can still be made using known attributes. If new attributes are added to an entry they are
viable until entry is refreshed. Other applications do not show similar difficulty in browsing
ldap. Occurs on multiple platforms (Unix/Linux/Windows) with LDAP at various stages of maturity.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message