Yeap sounds good and like what we discussed.
On side note though what about the using the 'I' prefix for interfaces? Like IFoo and IBar etc. I personally don't like it but many projects seem to use it.
Not trying to rehash this but I just want your input again ...
sorry to rehash the question...
A while back, we took a decision regarding names for interface
implementation. We had several different names all over the code, like
XXXImpl, BasicXXX, DefaultXXX, ConcreteXXX, BaseXXX where XXX is the
interface name. I think we agreed on the "Default" prefix, as far as I
can remember and find on gmail.
For ServerEntry, this will give :
(abstract class) AbstractServerEntry
(class implementation) DefaultServerEntry
Is that ok for everybody ?