Hehe, no pb.

I knew something was wrong... ;)

I managed to build everything but I had to do it from the root (/) directory. I tried as it is in the documentation (/studio) but I got an error.

I'm going to play with it now and give some feedback on the Mac OS X side of the build.

Thanks.
Pierre-Arnaud

On Dec 13, 2007 5:56 PM, Felix Knecht <felixk@apache.org> wrote:
Pierre-Arnaud Marcelot schrieb:
> Hi Felix,
>
> Thanks for answering.

Arghh, my fault, but I can't remember why I added the plugin itself to the pom.xml.

Big Sorry,
Felix


>
> I followed the instructions on this page and I was actually trying to
> build the maven-studio-plugin when I got the error.
> I was in the /studio-plugin folder...
>
> Thanks,
> Pierre-Arnaud
>
> On Dec 13, 2007 5:08 PM, Felix Knecht <felixk@apache.org
> <mailto: felixk@apache.org>> wrote:
>
>     Pierre-Arnaud Marcelot schrieb:
>     > Hi Guys,
>     >
>     > Sorry for the delay in answering, I was quite occupied lately.
>     >
>     > I got an error when trying out the mavenized build.
>     >
>     > Here's what I've done:
>     > I've cleaned my local maven repo ($ rm -rf ~/.m2)
>     > I've run 'mvn clean install' on the latest update of the ApacheDS
>     trunk
>     > And then the following commands:
>     > $ svn co https://svn.apache.org/repos/asf/directory/sandbox/felixk/
>     > < https://svn.apache.org/repos/asf/directory/sandbox/felixk/ >
>     > StudioMavenized
>     > $ cd StudioMavenized/studio-plugin
>     > $ mvn install
>     >
>     > Here's what I get:
>     > [INFO] Scanning for projects...
>     > [INFO]
>     >
>     ----------------------------------------------------------------------------
>     >
>     > [INFO] Building Apache Directory Studio Plugin
>     > [INFO]    task-segment: [clean]
>     > [INFO]
>     >
>     ----------------------------------------------------------------------------
>     > [INFO]
>     >
>     ------------------------------------------------------------------------
>     > [ERROR] BUILD FAILURE
>     > [INFO]
>     >
>     ------------------------------------------------------------------------
>     > [INFO] A required plugin was not found: Plugin could not be found -
>     > check that the goal name is correct: Unable to download the artifact
>     > from any repository
>     >
>     <snip/>
>     >
>     >
>     > Am I missing something?
>
>     Yes, you need to build the maven-studio-plugin first on its own. I
>     wasn't able until now to integrate it in the overall build. See also
>     http://cwiki.apache.org/confluence/x/CRoB
>
>     Felix
>
>
>