directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrique Rodriguez" <enriqu...@gmail.com>
Subject Re: Configuration in bigbang branch: names of SASL attributes and elements
Date Tue, 01 Jan 2008 00:01:31 GMT
On Dec 30, 2007 10:37 AM, Stefan Zoerner <stefan@labeo.de> wrote:
> ...
> But I had also to modify the value of attribute "searchBaseDn". I assume
> this value is only used for user detection in SASL. I therefore propose
> the name saslSearchBaseDn in order to make this consistent.

Yes, this DN is only for finding users for purposes of authentication.

> Another element name I wondered about was "supportedMechanisms". I
> recommend to rename it to "supportedSaslMechanisms", because this is the
> name used in the Root DSE for publication. In fact, it is
> supportedSASLMechanisms, but this does not fit the name scheme.

The issue here is that the 'supportedMechanisms' property allows you
to enable/disable support for SIMPLE authentication and SIMPLE is not
technically a SASL mechanism.

Enrique

Mime
View raw message