directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Custine" <ccust...@apache.org>
Subject Re: [New Entry API] Name for classes
Date Sat, 15 Dec 2007 17:40:51 GMT
Just in case you wanted another opinion to reinforce this, I don't like IFoo
for interface naming either.  Hopefully we will never get a suggestion to
prefix class member variables with m_ xxx either (m_foo).  These are both
pet peeves of mine.  :-D

Chris

On Dec 15, 2007 9:53 AM, Emmanuel Lecharny <elecharny@gmail.com> wrote:

> I think we decided that 'I' stands for Idiot in code ...
>
> PS : I don't maen I'm an Idiot ;)
>
> Alex Karasulu wrote:
> > Felix,
> >
> > These are all good points which for some reason this morning I could
> > not think about myself.  Thanks for showing me again why I don't like
> > this I stuff.
> >
> > Really though I don't like the "I" prefix because it reminds me of Mac
> > and the Mac Store which I hate because of all those moronic
> > metro-sexual sales snobs that think they know something ... :)
> >
> > Thanks,
> > Alex
> >
> > On Dec 15, 2007 11:16 AM, Felix Knecht <felixk@apache.org
> > <mailto:felixk@apache.org>> wrote:
> >
> >     Alex Karasulu schrieb:
> >     > Yeap sounds good and like what we discussed.
> >     >
> >     > On side note though what about the using the 'I' prefix for
> >     interfaces?
> >     > Like IFoo and IBar etc.  I personally don't like it but many
> >     projects
> >     > seem to use it.
> >
> >     I don't like it either
> >     - It could also mean Internal, Integration, I... (so you'll need
> >     to document it and read documentation anyway)
> >     - So it's just one more character (interpretable)
> >     - Imaging what happens e.b. when you type I and hit CTRL-Space in
> >     Eclipse :-(
> >
> >     I'm absolutely fine without 'I'
> >
> >     I haven't had a look a the code so maybe it's just a useless note,
> >     but IMO it makes (if ever) more sense having
> >     interface and implementation split into different modules for api
> >     (interfaces) and implementation.
> >
> >     Just my 2 cents
> >
> >
> >     Regards
> >     Felix
> >
> >     >
> >     > Not trying to rehash this but I just want your input again ...
> >     >
> >     > Cheers,
> >     > Alex
> >     >
> >     > On Dec 15, 2007 9:31 AM, Emmanuel Lecharny <elecharny@gmail.com
> >     <mailto:elecharny@gmail.com>
> >     > <mailto: elecharny@gmail.com <mailto:elecharny@gmail.com>>>
wrote:
> >     >
> >     >     Hi guys,
> >     >
> >     >     sorry to rehash the question...
> >     >
> >     >     A while back, we took a decision regarding names for interface
> >     >     implementation. We had several different names all over the
> >     code, like
> >     >     XXXImpl, BasicXXX, DefaultXXX, ConcreteXXX, BaseXXX where
> >     XXX is the
> >     >     interface name. I think we agreed on the "Default" prefix,
> >     as far as I
> >     >     can remember and find on gmail.
> >     >
> >     >     For ServerEntry, this will give :
> >     >
> >     >     (interface) ServerEntry
> >     >     (abstract class) AbstractServerEntry
> >     >     (class implementation) DefaultServerEntry
> >     >
> >     >     Is that ok for everybody ?
> >     >
> >     >     Thanks !
> >     >
> >     >     --
> >     >     --
> >     >     cordialement, regards,
> >     >     Emmanuel L├ęcharny
> >     >     www.iktek.com <http://www.iktek.com> < http://www.iktek.com>
> >     >     directory.apache.org <http://directory.apache.org>
> >     <http://directory.apache.org>
> >     >
> >     >
> >     >
> >
> >
>
>
> --
> --
> cordialement, regards,
> Emmanuel L├ęcharny
> www.iktek.com
> directory.apache.org
>
>
>

Mime
View raw message