Yes, I completely removed ~/.ApacheDirectoryStudio  several times while I was testing the issue.  I also re-installed several times and tried using several different JDKs each time to make sure it wasn't a bug in Java collections or something.  Same result with JDK 1.5 and 1.6.

Hope this info helps...

Thanks,
Chris

On 9/2/07, Pierre-Arnaud Marcelot <pa@marcelot.net > wrote:
Hey Chris,

I had this too, but only when I was working with an old Apache Directory Studio repository (~/.ApacheDirectoryStudio).

Are you sure you removed this directory before starting AD Studio ?

Thanks,

P-A


On 9/2/07, Chris Custine < ccustine@apache.org> wrote:
Hi Stefan and Pierre,
I have updated my local instance of Studio to 1.0 on Linux (as built by the 1.0 release tag) and found this potential bug.  I deleted my previous ~/.ApacheDirectoryStudio directory so that there were no conflicts and started from scratch so I am pretty sure it is an actual issue.

https://issues.apache.org/jira/browse/DIRSTUDIO-180

There is an easy workaround which is to disable the "Get Base DNs from root DSE" and set up the network tab, but the fist impression is confusing.  Also, as mentioned in the issue, it does not appear to happen on Windows, so I am not sure what is going on.

Chris