directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Birch (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSTUDIO-209) Cannot expand attribute list
Date Mon, 24 Sep 2007 23:59:50 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-209?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12530017
] 

Jim Birch commented on DIRSTUDIO-209:
-------------------------------------

Thanks Stefan.

I think I have the clue.

I've had a look at other rolled up attributes around the directory.  Some expanded, some didn't.
 Probably rules out OS and Java.  I haven't got another handy directory to test.

None of the (ou=user) MemberOf attribute lists would expand.

 Everything else did...UNTIL I found a rolled up attribute at the BOTTOM of the attribute
list.  Checked out more.  Same, roll ups in the last position wouldn't expand. I'd say that's
it.  At a high probability :-)

BTW I have two other funnies, I don't think these would affect attribute-level issues, but
just in case:

1.  I get an error dialog saying "Reading Children / Error while reading entry / Unprocessed
Continuation Reference(s)" on first browsing the tree.  I've found references to this but
not in DirStudio, eg [http://confluence.atlassian.com/display/CROWD/2.2.2+Configuring+an+LDAP+Directory+Connector]
saying that a java.naming.referral option is required.  I can't see how to set this in DirStudio.

2.  The directory is a big corporate AD, guess, 10k users, 2K groups (!).  DirStudio only
browses the first 1000 entries at any node but more can be found using searches.  I can't
find how to bump this limit, so my browse is typically not complete.

Regards


 

> Cannot expand attribute list
> ----------------------------
>
>                 Key: DIRSTUDIO-209
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-209
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-ldapbrowser
>    Affects Versions: 1.0.1
>         Environment: win2k + jre1.6.0_02 + Apache Directory Studio 1.0.1 > ActiveDirectory
>            Reporter: Jim Birch
>         Attachments: after_expand.gif, before_expand.gif
>
>
> Expand of grouped attributes fails.
> A search for directory object lists a group of attributes "memberOf (39 values)".  When
the expand icon is clicked, it disappears but the attribute list doesn't display.  Screenshots
coming.
>   

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message