directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicholas Irving (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DIRTSEC-11) When using smtp authentication in configuration wizard, the generated web.xml for demo and registration do not pass validation on Jetty startup
Date Sun, 30 Sep 2007 23:17:51 GMT

     [ https://issues.apache.org/jira/browse/DIRTSEC-11?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nicholas Irving updated DIRTSEC-11:
-----------------------------------

    Summary: When using smtp authentication in configuration wizard, the generated web.xml
for demo and registration do not pass validation on Jetty startup  (was: When using smtp authnetication
in configuration wizard, the generated web.xml for demo and registration do not pass validation
on Jetty startup)

> When using smtp authentication in configuration wizard, the generated web.xml for demo
and registration do not pass validation on Jetty startup
> -----------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DIRTSEC-11
>                 URL: https://issues.apache.org/jira/browse/DIRTSEC-11
>             Project: Triplesec
>          Issue Type: Bug
>         Environment: Windows XP sp2, PIII 500, 256 Meg Ram
>            Reporter: Nicholas Irving
>            Priority: Trivial
>
> When selecting Authentication for SMTP Servers, the generated web.xml for deom and registration
have the following issue.
>     <init-param>
>       <param-name>smsTransportUrl</param-name>
>       <param-value>http://demo.safehaus.org/smstrial/smspush</param-value>
>     </init-param>
>     <load-on-startup>1</load-on-startup>
>     <init-param>
>       <param-name>smtpUsername</param-name>
>       <param-value>xxx</param-value>
>     </init-param>
>     <init-param>
>       <param-name>smtpPassword</param-name>
>       <param-value>xxxxx</param-value>
>     </init-param>
> In order to resolve the validation issue you need to ensure that <load-on-startup>1</load-on-startup>
is after the last init-param like so
>     <init-param>
>       <param-name>smsTransportUrl</param-name>
>       <param-value>http://demo.safehaus.org/smstrial/smspush</param-value>
>     </init-param>
>     <init-param>
>       <param-name>smtpUsername</param-name>
>       <param-value>xxx</param-value>
>     </init-param>
>     <init-param>
>       <param-name>smtpPassword</param-name>
>       <param-value>xxxxx</param-value>
>     </init-param>
>     <load-on-startup>1</load-on-startup>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message