U trying to delete this DN?


This is not a correct DN it seems.


On 8/18/07, Ole Ersoy (JIRA) <jira@apache.org> wrote:

    [ https://issues.apache.org/jira/browse/DIRSERVER-942?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12520900 ]

Ole Ersoy commented on DIRSERVER-942:

Here's the output when I crtl-c to close the debugging session:
[16:10:47] ERROR [org.apache.directory.shared.ldap.codec.LdapMessageGrammar ] - The DN to delete : monkeywrench,ou=syntaxes,cn=xsd,ou=system (0x6D 0x6F 0x6E 0x6B 0x65 0x79 0x77 0x72 0x65 0x6E 0x63 0x68 0x2C 0x6F 0x75 0x3D 0x73 0x79 0x6E 0x74 0x61 0x78 0x65 0x73 0x2C 0x63 0x6E 0x3D 0x78 0x73 0x64 0x2C 0x6F 0x75 0x3D 0x73 0x79 0x73 0x74 0x65 0x6D ) is invalid : Bad DN : monkeywrench,ou=syntaxes,cn=xsd,ou=system
[16:10:47] WARN [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler] - [/] Unexpected exception forcing session to close: sending disconnect notice to client.
java.io.IOException : Connection reset by peer
        at sun.nio.ch.FileDispatcher.read0(Native Method)
        at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:21)
        at sun.nio.ch.IOUtil.readIntoNativeBuffer(IOUtil.java :233)
        at sun.nio.ch.IOUtil.read(IOUtil.java:200)
        at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:236)
        at org.apache.mina.transport.socket.nio.SocketIoProcessor.read(SocketIoProcessor.java :267)
        at org.apache.mina.transport.socket.nio.SocketIoProcessor.process(SocketIoProcessor.java:241)
        at org.apache.mina.transport.socket.nio.SocketIoProcessor.access$500(SocketIoProcessor.java:44)
        at org.apache.mina.transport.socket.nio.SocketIoProcessor$Worker.run(SocketIoProcessor.java:559)
        at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:43)
        at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask (ThreadPoolExecutor.java:665)
        at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
        at java.lang.Thread.run(Thread.java:619)

> Server Feezes When Doing https://issues.apache.org/jira/browse/DIRSERVER-935
> ----------------------------------------------------------------------------
>                 Key: DIRSERVER-942
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-942
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: ldap
>    Affects Versions: 1.5.0
>            Reporter: Ole Ersoy
>             Fix For: 1.5.1
>         Attachments: CreateSyntaxEntrySelfContainedTest.java
> This is related to https://issues.apache.org/jira/browse/DIRSERVER-935
> By accident I tried running some code that deletes (935 looks up)
> entries that are not present.
> The server froze and I could not connect with LS
> anymore.
> First I assumed it crashed, so I tried doing
> ./apacheds start
> But I still could not connect
> so I tried doing
> ./apacheds stop
> ./aapcheds start
> and back to normal.
> I need to code a self contained test for this.
> Cheers,
> - Ole

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.