directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Pohle <apacheds.de...@webunity.de>
Subject Re: Building apacheds-1.0.3-trunks fails
Date Thu, 09 Aug 2007 10:51:18 GMT
Emmanuel,

my fault - did the mvn clean install now only on top level, then 
switched to apacheds\server-installers and did mvn install but the 
result is the same!

I am sorry to bother you with that fault, but I cannot find the reason 
why this error takes place.

Markus

Emmanuel Lecharny schrieb:
> Markus,
> 
> I meant mvn clean install on the top level, not in apacheds/server-installers :)
> 
> Sadly, I'm not in front of my own computer, so I can't test the build
> right now.
> 
> E.
> 
> On 8/9/07, Markus Pohle <apacheds.devel@webunity.de> wrote:
>> Hi Emmanuel,
>>
>> sorry no success with that... I'll post the result of the 'mvn clean
>> install' shot and maybe you can find the reason why it does not work.
>>
>> D:\Temp\apacheds-10-trunks>cd apacheds\server-installers
>>
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers>mvn clean install
>> [INFO] Scanning for projects...
>> [INFO]
>> ----------------------------------------------------------------------------
>> [INFO] Building ApacheDS Server Installers
>> [INFO]    task-segment: [clean, install]
>> [INFO]
>> ----------------------------------------------------------------------------
>> [INFO] [clean:clean]
>> [INFO] Deleting directory
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\target
>> [INFO] Deleting directory
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\target\classes
>> [INFO] Deleting directory
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\target\test-classes
>> [INFO] Deleting directory
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\target\site
>> [INFO] [resources:resources]
>> [INFO] Using default encoding to copy filtered resources.
>> [INFO] [compiler:compile]
>> [INFO] Compiling 1 source file to
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\target\classes
>> [INFO] [resources:testResources]
>> [INFO] Using default encoding to copy filtered resources.
>> [INFO] [compiler:testCompile]
>> [INFO] No sources to compile
>> [INFO] [surefire:test]
>> [INFO] No tests to run.
>> [INFO] [jar:jar]
>> [INFO] Building jar:
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\target\apacheds-server-installers-1.0.3-SNAPSHOT.jar
>> [WARNING] POM for 'izpack:standalone-compiler:pom:3.8.0:runtime' is
>> invalid. It will be ignored for artifact resolution. Reason: Failed to
>> validate POM for proj
>> ect izpack:standalone-compiler at Artifact
>> [izpack:standalone-compiler:pom:3.8.0:runtime]
>> [INFO] [daemon:generate {execution: default}]
>> cmd[0] = svn
>> cmd[1] = export
>> cmd[2] =
>> http://svn.apache.org/repos/asf/directory/apacheds/releases/build-1.0.2
>> cmd[3] =
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\target\images\src
>> svn: Die URL
>> ?\194?\187http://svn.apache.org/repos/asf/directory/apacheds/releases/build-1.0.2?\194?\171
>> existiert nicht
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Execution of ' svn export
>> http://svn.apache.org/repos/asf/directory/apacheds/releases/build-1.0.2
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers\t
>> arget\images\src ' resulted in a non-zero exit value: 1
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] For more information, run Maven with the -e switch
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 8 seconds
>> [INFO] Finished at: Thu Aug 09 12:21:03 CEST 2007
>> [INFO] Final Memory: 8M/16M
>> [INFO]
>> ------------------------------------------------------------------------
>>
>> D:\Temp\apacheds-10-trunks\apacheds\server-installers>
>>
>> Emmanuel Lecharny schrieb:
>>> Hi Markus,
>>>
>>> could you try a 'mvn clean install' command when building the whole
>>> project, instead of a 'mvn install' ?
>>>
>>> On 8/8/07, Markus Pohle <apacheds.devel@webunity.de> wrote:
>>>> Hi List-users,
>>>>
>>>> tried to build the latest trunks of apacheds-1.0.x as descriped on this site:
>>>> http://directory.apache.org/apacheds/1.0/building.html
>>>>
>>>> Used maven 2.0.4 and JDK1.5.0_10 on Windows XP SP2 and SVN for Windows
>>>> Version 1.4.4.
>>>>
>>>> Started build with clean maven repository. The checkout command "svn
>>>> co http://...." was successful. The ongoing "mvn install" command was
>>>> also successful.
>>>>
>>>>
> 
> 

Mime
View raw message