directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DIRSERVER-922) Data is "lost" after adding Index to config file
Date Sun, 26 Aug 2007 01:15:30 GMT

     [ https://issues.apache.org/jira/browse/DIRSERVER-922?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alex Karasulu updated DIRSERVER-922:
------------------------------------

    Fix Version/s:     (was: 1.5.1)
                   1.5.2

Hey guys we can push this issue out to the next release.  I'd also like to simplify this code
so it does just command line things clearly like the old code did it.  Then we can add this
import command and just close this issue.

> Data is "lost" after adding Index to config file
> ------------------------------------------------
>
>                 Key: DIRSERVER-922
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-922
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 1.5.0
>         Environment: amd64
> 128M RAM
> 768 Swap
> prebuilt i386 apacheds-1.5.0
>            Reporter: Martin Marcher
>            Assignee: Pierre-Arnaud Marcelot
>             Fix For: 1.5.2
>
>
> Install Server
> add sevenseas Partition without any indexes (no property tag for indexes here at all)
> start server
> connect with LDAPStudio 0.8 (do not disconnect!)
> Load o=sevenSeas SampleData
> open server.xml Config file
> copy indexes from examplePartition to sevenSeasPartition
> don't yet save the file
> stop the server
> save server.xml
> start the server gain
> LDAPStudio will not show any data under o=sevenSeas.  (Note: Do not close the connection
and reconnect)
> When Trying to add the data again you will find that it is still there
> as importing again throws errors.
> This is is also the case when closing connection and reopening the connection
> as well as quitting ldapstudio and restarting it
> reloading "this entry and all it's children" didn't help
> reloading schema didn't help either.
> greets
> martin

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message