directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Zoerner <ste...@labeo.de>
Subject [ApacheDS] New Configuration: Unable to enable ldaps on port 636
Date Sun, 10 Jun 2007 19:48:24 GMT
Hi all!

I tried to enable ldaps with the new configuration which is part of the 
current 1.5.1-SNAPSHOT of ApacheDS.

This is what I tried:

<bean id="ldapsConfiguration" 
class="org.apache.directory.server.ldap.LdapConfiguration">
     <!-- Whether to enable the LDAPS protocol. 
       -->
     <property name="enabled" value="true" />
     <!-- The port to run the LDAPS protocol on. 
       -->
     <property name="ipPort" value="636" />

     <property name="ldapsCertificateFile" 
value="C:/java/apacheds-1.5.1-SNAPSHOT/conf/zanzibar.ks" />
     <property name="ldapsCertificatePassword" value="secret" />

</bean>

Unfortunately, it does not work. The server starts but does not listen 
on port 636 (10389 with plain ldap only). There is no message in the 
logs, and when I try to connect to the server via ldaps/636 I get a 
"connection refused".

Has anybody already setup ldaps and can give me a hint, if I have lost 
something in configuration ...

Thanks in advance,
     Stefan



Mime
View raw message