directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ole Ersoy (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSERVER-973) Unexpected Exception When Creating Meta ObjectClass Without :Optional Attributes
Date Sun, 17 Jun 2007 23:48:26 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-973?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12505635
] 

Ole Ersoy commented on DIRSERVER-973:
-------------------------------------

I think the cause of the NPE is that I quoted the "m-oid" attribute value  After fixing it,
I get a different exception:

org.apache.directory.shared.ldap.exception.LdapSchemaViolationException: Required attributes
[2.5.4.0] not found within entry m-oid=1.3.6.1.4.1.18060.0.4.0.3.1.555.55.55,ou=objectClasses,cn=apachemeta,ou=schema
	at org.apache.directory.server.core.schema.SchemaService.assertRequiredAttributesPresent(SchemaService.java:1851)

I tried it with both "metaObjectClass" and "metaObjectclass" values. 

> Unexpected Exception When Creating Meta ObjectClass Without :Optional Attributes
> --------------------------------------------------------------------------------
>
>                 Key: DIRSERVER-973
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-973
>             Project: Directory ApacheDS
>          Issue Type: Bug
>            Reporter: Ole Ersoy
>         Attachments: ObjectClassCreateTest.java
>
>
> I was creating this test to show that when creating meta objectclass entries, invalid
names are allowed.  However, the same name cannot be used as the value of the m-supObjectclass
attribute of meta objectclasses.  When I run the test I get this exception:
> org.apache.directory.server.core.interceptor.InterceptorException: Unexpected exception.
[Root exception is java.lang.NullPointerException]
> 	at org.apache.directory.server.core.interceptor.InterceptorChain.throwInterceptorException(InterceptorChain.java:1515)
> To run the test just drop it into an instance of the testing archetype and remember to
update the dependencies :-):
>     <dependency>
>         <groupId>org.apache.directory.server</groupId>
>         <artifactId>apacheds-core</artifactId>
>         <version>1.5.1-SNAPSHOT</version>
>       </dependency>
> Cheers,
> - Ole

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message