directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ole Ersoy (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (DIRSERVER-970) Hot Partition Fails With ArrayIndexOutOfBoundsException
Date Fri, 15 Jun 2007 20:04:26 GMT

     [ https://issues.apache.org/jira/browse/DIRSERVER-970?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ole Ersoy reopened DIRSERVER-970:
---------------------------------


I'm reopening this.  It's the same exception, but different cause.  I tried copying some of
the classes from the testing archetype to a different project.  When I ran them, I get the
same exception.  Finally I remembered that the classes need the log4j.properties file, otherwise
the embedding will not work.  

To see this in action, check out the testing archetype in my sandbox.  Run ADSEmbeddedHotPartitionTest.
 Then remove the log4j configuration file from the test/resources directory.

Here's the link to the testing archetype
svn co https://svn.apache.org/repos/asf/directory/sandbox/oersoy/apacheds.testing.archetype



> Hot Partition Fails With ArrayIndexOutOfBoundsException
> -------------------------------------------------------
>
>                 Key: DIRSERVER-970
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-970
>             Project: Directory ApacheDS
>          Issue Type: Bug
>            Reporter: Ole Ersoy
>         Attachments: IndependentHotPartitionTest.java
>
>
> After building the ApacheDS trunk on my machine, I started getting strange results when
running tests.  So I cleaned out the Maven repository completely, rebuilt ADS, and started
from scratch.  Now when I try to run the attached test (Needs a running server), I get this:
> java.lang.ArrayIndexOutOfBoundsException: 0
> 	at org.apache.directory.shared.ldap.schema.AbstractSchemaObject.toString(AbstractSchemaObject.java:320)
> 	at java.lang.String.valueOf(String.java:2827)
> 	at java.lang.StringBuilder.append(StringBuilder.java:115)
> 	at org.apache.directory.server.schema.registries.DefaultSyntaxRegistry.register(DefaultSyntaxRegistry.java:110)
> 	at org.apache.directory.server.core.schema.PartitionSchemaLoader.loadSyntaxes(PartitionSchemaLoader.java:654)
> 	at org.apache.directory.server.core.schema.PartitionSchemaLoader.load(PartitionSchemaLoader.java:348)
> 	at org.apache.directory.server.schema.registries.AbstractSchemaLoader.loadDepsFirst(AbstractSchemaLoader.java:103)
> 	at org.apache.directory.server.core.schema.PartitionSchemaLoader.loadWithDependencies(PartitionSchemaLoader.java:320)
> 	at org.apache.directory.server.core.schema.PartitionSchemaLoader.loadEnabled(PartitionSchemaLoader.java:222)
> 	at org.apache.directory.server.core.DefaultDirectoryService.initialize(DefaultDirectoryService.java:914)
> 	at org.apache.directory.server.core.DefaultDirectoryService.startup(DefaultDirectoryService.java:254)
> 	at org.apache.directory.server.core.jndi.AbstractContextFactory.getInitialContext(AbstractContextFactory.java:118)
> 	at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:667)
> 	at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288)
> 	at javax.naming.InitialContext.init(InitialContext.java:223)
> 	at javax.naming.ldap.InitialLdapContext.<init>(InitialLdapContext.java:134)
> 	at org.apache.tuscany.das.ldap.learning.test.IndependentHotPartitionTest.createDASPartition(IndependentHotPartitionTest.java:80)
> 	at org.apache.tuscany.das.ldap.learning.test.IndependentHotPartitionTest.testCreateDASPartition(IndependentHotPartitionTest.java:30)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message