directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrique Rodriguez" <enriqu...@gmail.com>
Subject Re: Trunk breakage...
Date Fri, 25 May 2007 19:19:55 GMT
On 5/25/07, Emmanuel Lecharny <elecharny@gmail.com> wrote:
> I just svn up the trunk this morning (Paris time), and tried to build
> it, but got some error in integration tests
> (https://issues.apache.org/jira/browse/DIRSERVER-943)
>
> I have commented to failing test :
> http://svn.apache.org/viewvc?view=rev&rev=541686

Thanks for opening the JIRA issue.  Commenting out the test was the
right response.

> Would you please check what is going wrong with it? I have tested the
> trunk on mu linux laptop and on my mac OSX, and Alex is experiencing
> the same breakage.

This is the issue Alex and I discussed after his review of the SASL
branch.  The Sun Kerberos provider doesn't allow you to change the
port (in code), so the integration test needs to bind to port 88
(Kerberos), which it can't do unless you're root.  We discussed some
solutions but I didn't get a chance to implement one before the merge.

We discussed writing a Kerberos client library, for a number of
reasons, one of which is to allow port selection like we do with the
LDAP integration tests.  I think the only solution in the short term
is to set up a profile for this test.

> Did you run mvn -Dintegration test before committing? If so, do you
> use a special configuration we don't use ? (Like W$ or JDK 1.6)

I ran these tests as root.

Enrique

Mime
View raw message