directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ceren KOKSAL" <cerenkok...@gmail.com>
Subject Fwd: Using Apache ds in a web application - user names, passwords
Date Tue, 22 May 2007 20:19:55 GMT
Localhost log says:
SEVERE: Exception sending context initialized event to listener instance of
class org.apache.directory.samples.embed.webapp.StartStopListener
java.lang.NoClassDefFoundError:
org/apache/directory/server/schema/registries/SchemaLoader

How can I solve this?

---------- Forwarded message ----------
From: Ceren KOKSAL <cerenkoksal@gmail.com>
Date: May 22, 2007 11:14 PM
Subject: Re: Using Apache ds in a web application - user names, passwords
To: Apache Directory Developers List <dev@directory.apache.org>,
seelmann@apache.org

I applied the instructions that you said.Build was succesful, then I
deployed the war on the Tomcat server.I listed applications on the server
and ApacheDS ' s running status is false. There is a message like this:

FAIL - Application at context path /ApacheDS could not be started


And when I type in the browser, http://localhost:8080/ApacheDS/RootDse, it
still says

*type* Status report

*message* */ApacheDS/RootDse*

*description* *The requested resource (/ApacheDS/RootDse) is not available.*
I tried while Apacheds is closed and tried while open.But gives the same
message:(..?

On 5/22/07, Stefan Seelmann <seelmann@apache.org> wrote:
>
> I was curious and just tested it:
> - I downloaded and unzipped the  ApacheDSWebApp.zip
> - I adjusted the path to ApacheDS and Tomcat in the build.xml file
> - then I run ant, that generated the AapcheDS.war
> - I deployed the war into tomcat
>
> Then I got an error in the catalina.out:
> ------------------------------------------------
> [20:50:28] ERROR [ org.apache.directory.server.jndi.ServerContextFactory]
> - Failed to bind an LDAP
> service (10389) to the service registry.
> java.net.BindException: Address already in use
> --------------------------------------------------
>
> The cause is that another ApacheDS was running on port 10389. After
> stopping the other ApacheDS and restarting Tomcat it works fine.
>
> Regards,
> Stefan Seelmann
>
>
> Stefan Zoerner schrieb:
> > Hi Ceren!
> >
> > StefanS is right, URL should be as defined in the url-pattern of the
> > WebApp. Have you checked the logs of your Tomcat? One possible thing is
> > that there are libraries missing in  the WEB-INF/lib folder. This should
>
> > raise an exception in the Tomcat logs, if the WebApp starts (not if the
> > browser requests the servlet it, by the way ...)
> >
> > Greetings,
> >     StefanZ
> >
> > Stefan Seelmann wrote:
> >> Hi Ceren,
> >>
> >> please check the web.xml, there you could find the URL pattern which is
> >> mapped to the RootDseServlet:
> >>
> >> ----------------------------------------------
> >> <servlet-mapping>
> >>   <servlet-name>RootDseServlet</servlet-name>
> >>   <url-pattern>/RootDse</url-pattern>
> >> </servlet-mapping>
> >> ----------------------------------------------
> >>
> >> So could you please try the URL http://localhost:8080/ApacheDS/RootDse?
> >>
> >> Regards,
> >> Stefan Seelmann
> >
>
>

Mime
View raw message