directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Roth (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSTUDIO-80) LDAP Studio does not work on x86_64
Date Mon, 14 May 2007 16:50:16 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-80?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12495673
] 

Andreas Roth commented on DIRSTUDIO-80:
---------------------------------------

I tried it once more and finally i got it up and running.
I had to copy the startup.jar and the eclipse binary executable file from eclipse and put
it into the ldap studio directory.

So here are the step to get it running on AMD64:
- download the i386 package
- unzip it to an empty directory
- cd into the ldapstudio directory
- cp /usr/share/eclipse/startup.jar .
- cp /usr/share/eclipse/eclipse ./ldapstudio
- cp /usr/share/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar plugins/
- run ./ldapstudio

> LDAP Studio does not work on x86_64
> -----------------------------------
>
>                 Key: DIRSTUDIO-80
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-80
>             Project: Directory LDAP Studio
>          Issue Type: Bug
>    Affects Versions: 0.7.0
>         Environment: AMD64
>            Reporter: Andreas Roth
>         Assigned To: Pierre-Arnaud Marcelot
>             Fix For: 0.9.0
>
>
> LDAP Studio cannot be started on AMD64. The following lines are in the log file.
> !SESSION 2007-04-12 18:44:11.924 -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.5.0_10
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
> Command-line arguments:  -os linux -ws gtk -arch x86
> !ENTRY org.eclipse.osgi 4 0 2007-04-12 18:44:13.588
> !MESSAGE Application error
> !STACK 1
> java.lang.UnsatisfiedLinkError: /local/work/LDAP Studio/configuration/org.eclipse.osgi/bundles/40/1/.cp/libswt-pi-gtk-3235.so:
Can't load IA 32-bit .so on a AMD 64-bit platform
>         at java.lang.ClassLoader$NativeLibrary.load(Native Method)
>         at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
>         at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1660)
>         at java.lang.Runtime.loadLibrary0(Runtime.java:822)
>         at java.lang.System.loadLibrary(System.java:993)
>         at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
>         at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
>         at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
>         at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
>         at org.eclipse.swt.widgets.Display.<clinit>(Display.java:126)
>         at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:433)
>         at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
>         at org.apache.directory.ldapstudio.Application.run(Application.java:53)
>         at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
>         at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
>         at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
>         at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
>         at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:585)
>         at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
>         at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
>         at org.eclipse.core.launcher.Main.run(Main.java:977)
>         at org.eclipse.core.launcher.Main.main(Main.java:952)
> !ENTRY org.eclipse.osgi 2 0 2007-04-12 18:44:13.621
> !MESSAGE One or more bundles are not resolved because the following root constraints
are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-04-12 18:44:13.622
> !MESSAGE Bundle update@plugins/org.eclipse.sdk_3.2.1.r321_v20060705/ was not resolved.
> !SUBENTRY 2 org.eclipse.sdk 2 0 2007-04-12 18:44:13.622
> !MESSAGE Missing required bundle org.eclipse.ui.cheatsheets_[3.2.0,4.0.0).
> !ENTRY org.eclipse.osgi 2 0 2007-04-12 18:44:13.622
> !MESSAGE The following is a complete list of bundles which are not resolved, see the
prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-04-12 18:44:13.623
> !MESSAGE Bundle update@plugins/org.eclipse.sdk_3.2.1.r321_v20060705/ [38] was not resolved.
> !SUBENTRY 2 org.eclipse.sdk 2 0 2007-04-12 18:44:13.623
> !MESSAGE Missing required bundle org.eclipse.ui.cheatsheets_[3.2.0,4.0.0).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message