Oh thanks for the heads up.  Yeah 64 bit stuff get's wacky sometimes.  That's why I never bought one of those machines and still probably will not.

With this knowledge I will make sure we qualify the jvm type for these machines while diagnosing any issues that may arrise.

Thanks,
Alex

On 4/19/07, Ole Ersoy <ole.ersoy@gmail.com> wrote:
Alex,

Just a couple of notes that might come in handy.  I'm running on AMD 64,
and I get segfaults all the time from Maven, Eclipse, everything.

I tried it with the 64 bit JVM first, and then downgraded to 32 bit,
and the 32 bit is better, but I still get segfaults at least 3 times a
day.

I think java just has a lot of bugs that need to be worked out before it
runs cleanly on a 64 bit CPU.

Cheers,
- Ole



Alex Karasulu (JIRA) wrote:
>      [ https://issues.apache.org/jira/browse/DIRSERVER-751?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
>
> Alex Karasulu updated DIRSERVER-751:
> ------------------------------------
>
>     Affects Version/s: 1.5.0
>                        1.0.1
>                        1.0
>         Fix Version/s: 1.0.2
>
> I'm going to try to fix this for 1.0.2 and 1.5.1 since I have the hardware to test this on now.
>
>> Jsvc fails on AMD 64-bit linux machines
>> ---------------------------------------
>>
>>                 Key: DIRSERVER-751
>>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-751
>>             Project: Directory ApacheDS
>>          Issue Type: Bug
>>    Affects Versions: 1.0.1, 1.5.0, 1.0, 1.0-RC4, 1.0-RC3, 1.0-RC2, 1.0-RC1, pre-1.0
>>         Environment: AMD 64
>> Ubuntu 6.06.1
>> JDK 1.5.0_08
>>            Reporter: Alex Karasulu
>>         Assigned To: Alex Karasulu
>>            Priority: Minor
>>             Fix For: 1.5.1, 1.0.2
>>
>>
>> The apacheds start command on the init script fails because the compiled binary for Jsvc segfaults on 64-bit machines.  I think we need a 64-bit version of ApacheDS installers with a jsvc binary compiled on a 64-bit linux machine.
>