I'm against this guys. These contstants are getting way too long. Typing them out is more of a hassle than just using the darn String for it. Like OU_AT will now be OU_ATTRIBUTE_TYPE. The convention for AT and OC are just fine. Extrapolate this to MATCHING_RULE and DIT_STRUCTURE_RULE etc and the code text gets filled up with long constant names for 2-3 letter strings. That defeats the purpose of using the constant in the first place. Just learn and stick with the convension.
Until we get significant familiarity by those new to the code base they should stop trying to alter our existing conventions without knowing the full impact.
Just as suggested by pam, AT stand for ATTRIBUTE_TYPE, not ATTRIBUTE--On 4/19/07, Emmanuel Lecharny < email@example.com > wrote:Ole Ersoy a écrit :
> I went ahead and scanned the constants files.
> If everyone is cool with it, I'll go ahead and
> update the interfaces so that:
> AT > ATTRIBUTE
> OC > OBJECT_CLASS
> and recommit.
> Sound ok?
Go for it, but before committing, run
mvn -Dintegration test
on the top level project.
If the test (20 minutes) is ok, then commit.