So are you suggesting explicit yet different method names for all these operations rather than using overloads?
As a side note: I prefer single most generic forms for all types of
the same operations. Having more than one forms of search, moddn
causes problems when writing complicated services like authorization
On 4/12/07, Alex Karasulu < email@example.com> wrote:
> Yeah I like your idea of using a MoveContext and a RenameContext along with
> a MoveAndRenameContext. This solves the problem quickly but I wonder if it
> is the best option.
> On 4/12/07, Emmanuel Lecharny <firstname.lastname@example.org> wrote:
> > Hi,
> > as I changed the interceptors operation to use instances of ServiceContext
> instead of multiple parameters, I'm facing a difficult semantic problem with
> the modifyDN operation. This operation gather three different semantics :
> > - a rename operation, if the RDN is changed, but not the base DN
> > - a move operation if the RDN is not changed but the base DN is changed
> > - and a move+rename operation if both RDN and base DN are changed
> > As I can't have two move() operations, because the signatureis now the
> same (move(ServiceContext)), so I wanted to rename the method, but which
> name using ? ... Another option would be to keep the two move() methods, but
> instead of using the ServcieContext interface, to use the specific sub-class
> : move( MoveContext ) and move( ChangeContext ), where the MoveContext is
> used if the RDN does not change, and the other one if it change.
> > wdyt ?
> > --
> > Cordialement,
> > Emmanuel Lécharny
> > www.iktek.com