directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: [CONSTANSTS] Conventions and Update
Date Sat, 14 Apr 2007 23:22:00 GMT
Ole Ersoy a écrit :

> Hey Guys,
>
> I noticed that we are missing:
>     String TOP_AT = "top";
>
> In SystemSchemaConstants.

May be because "top" is not an attribute type, but an object class :)

There is a TOP_OC = "top" in SchemaConstants.

>
> I was going to add it, but noticed that SystemSchemaConstants
> now only contains a single value:
>
> String SCHEMA_NAME = "system";
>
> Did the other stuff get moved?

Yes, foloowing one of your suggestion to gather all the constants 
somwhere. It's currently in the shared-constants project

>
> Also, I think our code would be much easier to read
> if we agree to use a set of conventions for naming
> constants.
>
> I personally would much rather see:
>
> String TOP_ATTRIBUTE_TYPE_NAME = "top";
> String CN_ATTRIBUTE_TYPE_NAME = "cn";

I buy this idea. Even if the name are a little bit long, there is a 
clear advantage to use them : AT and OC does not immediatly seems to be 
associated with AttributeType and ObjectClass. Can you create a JIRA 
with this suggestion ?

> <snip>

Emmanuel

Mime
View raw message